summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-26 08:54:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-26 09:22:27 +0100
commita64be5bc36d4e189a7bf3e5a7efdd3d0ce1e06b2 (patch)
treef5c07c43a92e053ccd1af46fae1c2987356ad0bb /dev-python/aiosmtpd
parentdev-libs/libmaxminddb: x86 stable wrt bug #771354 (diff)
downloadgentoo-a64be5bc36d4e189a7bf3e5a7efdd3d0ce1e06b2.tar.gz
gentoo-a64be5bc36d4e189a7bf3e5a7efdd3d0ce1e06b2.tar.bz2
gentoo-a64be5bc36d4e189a7bf3e5a7efdd3d0ce1e06b2.zip
dev-python/aiosmtpd: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest1
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.4.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
index 266ab9d2f22b..5eb2ce1d6b7c 100644
--- a/dev-python/aiosmtpd/Manifest
+++ b/dev-python/aiosmtpd/Manifest
@@ -2,3 +2,4 @@ DIST aiosmtpd-1.2.2.tar.gz 170459 BLAKE2B abf178c28a21c25e8a7c7ed920c154f037aaa2
DIST aiosmtpd-1.2.4.tar.gz 83329 BLAKE2B accecbc3fe66efc748d0bc3c85504d731005b907435fada5b3c7ae0f7778e89f19d7c15a7edb194a7ba6310a450132728557a441b3fb2958d3658b0a15d3ccf5 SHA512 dc6041e284daceb89f8ca83b5cd715a5811eb4cf76504c23112e24c97d6c88480667c713ce094c2dcbc5b12a80605e551b6aadc4b1ce499089be68c7c4e7df8c
DIST aiosmtpd-1.2.tar.gz 51457 BLAKE2B c2dba38c5d5a243a65c332cb3b6bf85a124eb6ab9c3526d0ef57788eb7e24e64ec86c56eeaa57e5171631c8a965447f125366741b1d1c54fb48473da5123ed40 SHA512 520b0fae80423d3963d4f17ef393cc0ce9e342fd1237c909159706bfe1e13f27df849fbc14aa1c94ad02e7c9108308984b6f9e21c7dbddb09093ef00884983d8
DIST aiosmtpd-1.3.2.tar.gz 110769 BLAKE2B 985684d8183c89670c362e39b81cbff187fa820bc3197a0c0c18cd61eb4c00912bf489d935303be0fedfee3dabfafaf81c7d4be3e428374624ed9a1fab6ce2c8 SHA512 b5d183671b8a985dcf774fb1b35ffbdf5c058e24e7cb81d77b2b0ce00b2b4dff27ff8bb167e985d5bf84cb6816c014d7cd601aab59243136ae409975ef3da30d
+DIST aiosmtpd-1.4.0.tar.gz 136307 BLAKE2B 5ae007be6953de8fd804bef25e290153ead6730bf44dbf71448946c1380a972a59b0fcf6f669035dd23acc582d697dc746efe0b03612e6c3ee51b31d58aee309 SHA512 cefbc819a51cbdacc8f24d0f5ff4f2a92ad6e4c5809a9b97635226767f1dd20c63565522ab66fd6c7ede5efdafa89c42e3c3bae4e94ea5c57b49531b02e1bad6
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.4.0.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.4.0.ebuild
new file mode 100644
index 000000000000..3c32f8604a09
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+# TODO: run doctests using sphinx?
+distutils_enable_tests pytest