summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-11-16 10:15:35 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-11-16 10:16:22 -0600
commit64d95172eba2d9a5561fe438073e4aea543bc7ca (patch)
treec8efd0c3aea58e69aaf2ba2de35e525a799a2f30 /dev-python/aiohttp
parentvirtual/python-dnspython: amd64 stable wrt bug #565742 (diff)
downloadgentoo-64d95172eba2d9a5561fe438073e4aea543bc7ca.tar.gz
gentoo-64d95172eba2d9a5561fe438073e4aea543bc7ca.tar.bz2
gentoo-64d95172eba2d9a5561fe438073e4aea543bc7ca.zip
dev-python/aiohttp: add version 0.18.4
x86 was dropped due to dev-python/pytest-raisesregexp. Bug #565956 has been filed to remedy this. Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-0.18.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 46577c7ac085..2c78b9541aea 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1,2 +1,3 @@
DIST aiohttp-0.14.4.tar.gz 1253273 SHA256 2338c8506ce7853ac2df7efba731a3fd015a7ee2561afab0d69ddefb43403f5a SHA512 453626e2acb2da85b39fd9dab01c51bbbbdf3422e2d7ff833e8be141f43d27d046646bafe6d58d96d37457208ecc2347a3724f056152c639c18de99da619538d WHIRLPOOL 42e8e23c3b1c28463617f9137288886ccf2d61fe404e8b06e105e0a48b36b06382a7a58a6e6c91bc38886e09874ba6112300fd6bf3adfce704129a7edbc4936d
DIST aiohttp-0.17.4.tar.gz 475034 SHA256 a2f122b41f29eb10772f1600ada5fec849c5dc717c1dcaa05c95bf0712af8843 SHA512 bca0aa93f51fae32eff383ffbd7790886a822647e77884fb5a26b6d2673429b61cf5483527297740a4b237b3e038934990df1061e32e6617d6a3da10276b9116 WHIRLPOOL a7abec0b3daa84078beee9057b5dfdf021b7522fa6b7f847f65008a061802f2cd61dee34886b833c8465f0a5379af9cb45b1f2117cd0b386b6ea488f3f9f2b3c
+DIST aiohttp-0.18.4.tar.gz 2165117 SHA256 23f1a5de84d0384ab2e78405db56be5e4af0681c42ddbc0caecf2402ddee3019 SHA512 ae4d72d661b2e69e9eb9d258d3c8842cd3e7a8a1d71dd71ccfbc7a3cf5916d65c82f3e3fe56731d5a326d810c01c32dbcb88900b7db68f3f5172c15e482aadc4 WHIRLPOOL 6b59b45e510472c8082868025e660c98e509760d87d08962b7fcc29680e1e31d89bf4e15d2559c7f202ebe70a28cc9eae4908c999cc7c0c29e4b6ea4ed2fbaaf
diff --git a/dev-python/aiohttp/aiohttp-0.18.4.ebuild b/dev-python/aiohttp/aiohttp-0.18.4.ebuild
new file mode 100644
index 000000000000..1f7cb32c1e3a
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-0.18.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://github.com/KeepSafe/aiohttp https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+CDEPEND=" dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-raisesregexp[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="$(PWD):${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}