summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-16 20:32:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-16 21:19:36 +0200
commitd3dd66ef8d59096bb9d31508825c3b5da38683dd (patch)
tree687a332b83f9c1ffd1ad1e0937e94266a12efd89 /dev-python/aiohappyeyeballs
parentdev-python/aiohappyeyeballs: Remove old (diff)
downloadgentoo-d3dd66ef8d59096bb9d31508825c3b5da38683dd.tar.gz
gentoo-d3dd66ef8d59096bb9d31508825c3b5da38683dd.tar.bz2
gentoo-d3dd66ef8d59096bb9d31508825c3b5da38683dd.zip
dev-python/aiohappyeyeballs: Bump to 2.3.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest1
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.6.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
index 32e07a4297f7..d87243d4f92f 100644
--- a/dev-python/aiohappyeyeballs/Manifest
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -1 +1,2 @@
DIST aiohappyeyeballs-2.3.5.gh.tar.gz 55133 BLAKE2B 09560b2616ecb6f2b496269f6d9589965b46f3be577fb8f3385a7f05d8af41c411d74320bbe6090e95bcea520167474b54866f56e16fce897062f11a58f26d03 SHA512 bd322bb62d9fe5e82e8b7380a9b769f670fb0cb2a653d31ccfd3c25e5dc58dde814291deecfc3d159ca13282fa149e654d8e4b16bc8a042d31f40318b6aadd2b
+DIST aiohappyeyeballs-2.3.6.gh.tar.gz 55205 BLAKE2B 7359b17a21e33247ea60a21c3303464e92841b8a6dbfb7c75380ce7bcc708f2f71e1041c6d976f467f99e16e55a22f516701a5439809dec4b6910b6a70c0d119 SHA512 637ac7f0fd5433f3f01b3289924fec53742d60f7b87696d2614c34e463324165135fe4111b2afb4499ed76d08a6759721aad5a2a6e62b227f1ff38cc936e0719
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.6.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.6.ebuild
new file mode 100644
index 000000000000..05fb16344a39
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}