summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-19 14:46:50 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-19 16:06:18 -0400
commitd39f8df3f36c900a2e7dd03818cf2bcf39facf82 (patch)
treebbf3c392c02609c382e7b34df3cd629b79bec3d5 /dev-python/PyQt6
parentkde-plasma/plasma-welcome: drop 5.27.4.1 (diff)
downloadgentoo-d39f8df3f36c900a2e7dd03818cf2bcf39facf82.tar.gz
gentoo-d39f8df3f36c900a2e7dd03818cf2bcf39facf82.tar.bz2
gentoo-d39f8df3f36c900a2e7dd03818cf2bcf39facf82.zip
dev-python/PyQt6: fix build with qtbase[-opengl]
On top of disabling the QtOpenGL bindings with USE=-opengl, also need to fully disable the OpenGL feature given it's also used in QtGui. Still not sure if this is all handled right for gles2-only, the logic is misleading. Closes: https://bugs.gentoo.org/904676 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/PyQt6-6.4.2.ebuild1
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.0.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.4.2.ebuild b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
index a330813b3bbe..b7539614ad4a 100644
--- a/dev-python/PyQt6/PyQt6-6.4.2.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
@@ -135,6 +135,7 @@ src_configure() {
$(usev !qml --no-qml-plugin)
$(usev !gles2-only --disabled-feature=PyQt_OpenGL_ES2)
+ $(usev !opengl --disabled-feature=PyQt_OpenGL)
$(usev !ssl --disabled-feature=PyQt_SSL)
)
}
diff --git a/dev-python/PyQt6/PyQt6-6.5.0.ebuild b/dev-python/PyQt6/PyQt6-6.5.0.ebuild
index cc79a2b35f27..4b7e6d33b9e8 100644
--- a/dev-python/PyQt6/PyQt6-6.5.0.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.0.ebuild
@@ -137,6 +137,7 @@ src_configure() {
$(usev !qml --no-qml-plugin)
$(usev !gles2-only --disabled-feature=PyQt_OpenGL_ES2)
+ $(usev !opengl --disabled-feature=PyQt_OpenGL)
$(usev !ssl --disabled-feature=PyQt_SSL)
)
}