summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-27 10:59:36 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-28 08:31:28 -0400
commit41041732549fd57cd9cf78bc4a7f95ecfb2f7726 (patch)
tree5646bcde7586d41d9965c7dfd198688dda762894 /dev-python/PyQt6
parentdev-python/PyQt6: check for qtdeclarative[widgets?] (diff)
downloadgentoo-41041732549fd57cd9cf78bc4a7f95ecfb2f7726.tar.gz
gentoo-41041732549fd57cd9cf78bc4a7f95ecfb2f7726.tar.bz2
gentoo-41041732549fd57cd9cf78bc4a7f95ecfb2f7726.zip
dev-python/PyQt6: tentatively drop qtbase's binding operator
Believe symbol issues had in the past were more of a fluke than the norm, not to mention this does not actually use _p.h headers. Takes a while to rebuild and forcing a rebuild on every Qt bump may not be worthwhile (back when added this, Qt used 0/a.b rather than 0/a.b.c so it was not that bad). May revert if get issues again. (would still cause one more rebuild but -r1 happened in an earlier commit either way) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild3
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.2.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild b/dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild
index b4ecd3978bb2..08010f0076ec 100644
--- a/dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.2-r1.ebuild
@@ -46,9 +46,8 @@ REQUIRED_USE="
widgets? ( gui )
"
-# can use parts of the Qt private api and "sometimes" needs rebuilds wrt :=
DEPEND="
- >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
+ >=dev-qt/qtbase-${QT_PV}[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]
diff --git a/dev-python/PyQt6/PyQt6-6.5.2.ebuild b/dev-python/PyQt6/PyQt6-6.5.2.ebuild
index c218d15abcb7..1cea7b121eaf 100644
--- a/dev-python/PyQt6/PyQt6-6.5.2.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.2.ebuild
@@ -45,9 +45,8 @@ REQUIRED_USE="
widgets? ( gui )
"
-# can use parts of the Qt private api and "sometimes" needs rebuilds wrt :=
DEPEND="
- >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
+ >=dev-qt/qtbase-${QT_PV}[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]