summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-09 18:59:10 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-09 19:43:51 +0100
commitfba3f9a01fb4ba00066e96473a5a425ee6f2106b (patch)
tree5ba22abf8a7c8fbb53349865036cf14b23d943c3 /dev-php
parentdev-php/PHPMailer: bump to v6.2.0 (diff)
downloadgentoo-fba3f9a01fb4ba00066e96473a5a425ee6f2106b.tar.gz
gentoo-fba3f9a01fb4ba00066e96473a5a425ee6f2106b.tar.bz2
gentoo-fba3f9a01fb4ba00066e96473a5a425ee6f2106b.zip
dev-php/pecl-redis: bump to v5.3.3
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-redis/Manifest1
-rw-r--r--dev-php/pecl-redis/pecl-redis-5.3.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
index 1153a3511698..813b8e24e426 100644
--- a/dev-php/pecl-redis/Manifest
+++ b/dev-php/pecl-redis/Manifest
@@ -1 +1,2 @@
DIST redis-5.3.2.tgz 266814 BLAKE2B 2be79d850e5958bcaf4fddcbdef0a402e62a522f260ae94c0fdc931a988e9b266c7a4e049b89b507a29a8e9085590e4077e336b85974d70a7cb9b3d6c806949d SHA512 95ce960b78cf94ecd212ec88914935167af37e4176d4b111dfc8c6f1a0846a34beba7f9f516cd7a5e1c9dda23f46cce44c99aaa5b42724c0c2a188b0698af414
+DIST redis-5.3.3.tgz 266990 BLAKE2B b939e5a33b3013d1aeaa59f9a1ebbb4b4665d57abf87dc4e300273221d3390d14387cad318d69a56ab573861c1aef89ab7778d3f636adfc351b4fc330eba98d3 SHA512 a04a7d0aa3881b861a00c3f0a889b2f3fd135009293629ac55a74890196c0686e9766438f5255561105e30293f1a6a91ca987fd68e43f3ca436f6cc884e6a5df
diff --git a/dev-php/pecl-redis/pecl-redis-5.3.3.ebuild b/dev-php/pecl-redis/pecl-redis-5.3.3.ebuild
new file mode 100644
index 000000000000..cc99909962e4
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-5.3.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_NAME="redis"
+USE_PHP="php7-2 php7-3 php7-4 php8-0"
+PHP_EXT_NEEDED_USE="json(+)?,session?"
+DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="igbinary +json lz4 +session zstd"
+
+DEPEND="
+ igbinary? ( >=dev-php/igbinary-3.0.1-r1[php_targets_php7-2(-)?,php_targets_php7-3(-)?,php_targets_php7-4(-)?,php_targets_php8-0(-)?] )
+ lz4? ( app-arch/lz4:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}
+ !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ --disable-redis-lzf
+ --disable-redis-msgpack
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable json redis-json)
+ $(use_enable lz4 redis-lz4)
+ $(use_with lz4 liblz4)
+ $(use_enable session redis-session)
+ $(use_enable zstd redis-zstd)
+ $(use_with zstd libzstd)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}