summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-08-07 09:39:26 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-08-07 13:02:00 -0400
commitfaa31ddf19ee012a44d9fdb7a374d4763a3faf34 (patch)
tree219c9f0687fd155dec21e8026948957c7d8c5d9f /dev-php
parentdev-scheme/racket: drop old 8.2-r3 (diff)
downloadgentoo-faa31ddf19ee012a44d9fdb7a374d4763a3faf34.tar.gz
gentoo-faa31ddf19ee012a44d9fdb7a374d4763a3faf34.tar.bz2
gentoo-faa31ddf19ee012a44d9fdb7a374d4763a3faf34.zip
dev-php/recaptcha: add 1.2.4
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/recaptcha/Manifest1
-rw-r--r--dev-php/recaptcha/recaptcha-1.2.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-php/recaptcha/Manifest b/dev-php/recaptcha/Manifest
index d82a9d1c40af..726ee9acd625 100644
--- a/dev-php/recaptcha/Manifest
+++ b/dev-php/recaptcha/Manifest
@@ -1 +1,2 @@
DIST recaptcha-1.2.1.tar.gz 19935 BLAKE2B 43077b25d484940951bf070fa440b5d13c6992c2a157e06b81961b9692683a277d9507e44102dd0ba0cde66c892fd4736ed34cae4b001bdce0d4ab619828b432 SHA512 62df22a6f4b05006a6051db689994e455ada43f76406dd62c5c13f1d90ae64401e9d75c6a92f2c620a14c070d2b49199c20e70eb6284e42e676d37412a98abe4
+DIST recaptcha-1.2.4.tar.gz 21762 BLAKE2B 46c00ac95f2d2643a719b8ea4b53f33f92357406168e057dbdb87fb1419dd6626d1032113ba5842c69bdacb385887563b52290a55a861b57ddcf494e325c0595 SHA512 7c0bee86e532547900a0131c2c52d9d3e427eb0465d7ae5ca2bd3ccbeb7620c8b3216313e4ab382013045310f928364c1284a77eee2f2216d5b241e2d275597d
diff --git a/dev-php/recaptcha/recaptcha-1.2.4.ebuild b/dev-php/recaptcha/recaptcha-1.2.4.ebuild
new file mode 100644
index 000000000000..de078821e3da
--- /dev/null
+++ b/dev-php/recaptcha/recaptcha-1.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PHP client library for Google's reCAPTCHA service"
+HOMEPAGE="https://github.com/google/recaptcha"
+SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/php"
+BDEPEND="test? ( ${RDEPEND} <dev-php/phpunit-8 )"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r src/autoload.php src/ReCaptcha
+ dodoc CONTRIBUTING.md README.md
+ use examples && dodoc -r examples
+}
+
+src_test() {
+ phpunit || die "test suite failed"
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/autoload.php'),"
+ elog "and then use the ${PN} class normally. Most of the examples in"
+ elog "the documentation should work without further modification."
+}