summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-09-29 12:49:51 -0400
committerBrian Evans <grknight@gentoo.org>2021-09-29 12:52:49 -0400
commitadda557b380f0fe8aa556f21b46dad360e57bb97 (patch)
treee32b24a6a88c1316ac14b0cfce0fc2e488ec029b /dev-php
parentapp-portage/recover-broken-vdb: destabilize 0.0.5 (diff)
downloadgentoo-adda557b380f0fe8aa556f21b46dad360e57bb97.tar.gz
gentoo-adda557b380f0fe8aa556f21b46dad360e57bb97.tar.bz2
gentoo-adda557b380f0fe8aa556f21b46dad360e57bb97.zip
dev-php/swoole-async: Fix build dependencies
swoole-async needs a specific version of dev-php/swoole to compile and work Revbump to ensure those using it get what is necessary Closes: https://bugs.gentoo.org/705492 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/swoole-async/swoole-async-4.4.12-r1.ebuild (renamed from dev-php/swoole-async/swoole-async-4.4.12.ebuild)5
-rw-r--r--dev-php/swoole-async/swoole-async-4.4.16-r1.ebuild (renamed from dev-php/swoole-async/swoole-async-4.4.16.ebuild)5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-php/swoole-async/swoole-async-4.4.12.ebuild b/dev-php/swoole-async/swoole-async-4.4.12-r1.ebuild
index 845bfc568cc0..aa4fbdf97a3a 100644
--- a/dev-php/swoole-async/swoole-async-4.4.12.ebuild
+++ b/dev-php/swoole-async/swoole-async-4.4.12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -26,7 +26,8 @@ SLOT="0"
# Tests will require pre-configured endpoint
RESTRICT="test"
-DEPEND=">=dev-php/swoole-4.3"
+# This will only compile with the same version of dev-php/swoole
+DEPEND="~dev-php/swoole-${PV}[php_targets_php7-1(-)?,php_targets_php7-2(-)?,php_targets_php7-3(-)?,php_targets_php7-4(-)?]"
RDEPEND="${DEPEND}"
diff --git a/dev-php/swoole-async/swoole-async-4.4.16.ebuild b/dev-php/swoole-async/swoole-async-4.4.16-r1.ebuild
index 09b9d48a22e1..aa4fbdf97a3a 100644
--- a/dev-php/swoole-async/swoole-async-4.4.16.ebuild
+++ b/dev-php/swoole-async/swoole-async-4.4.16-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -26,7 +26,8 @@ SLOT="0"
# Tests will require pre-configured endpoint
RESTRICT="test"
-DEPEND=">=dev-php/swoole-4.3"
+# This will only compile with the same version of dev-php/swoole
+DEPEND="~dev-php/swoole-${PV}[php_targets_php7-1(-)?,php_targets_php7-2(-)?,php_targets_php7-3(-)?,php_targets_php7-4(-)?]"
RDEPEND="${DEPEND}"