summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-16 14:50:47 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-16 16:59:53 -0500
commit8653e35b0d514f667684a8ea3d106f08a0c4b1ed (patch)
treee4e034f54f63f01ad498c015945c4dd64a887f88 /dev-php
parentdev-db/postgresql: stable 9.6.7 for ia64, bug #647246 (diff)
downloadgentoo-8653e35b0d514f667684a8ea3d106f08a0c4b1ed.tar.gz
gentoo-8653e35b0d514f667684a8ea3d106f08a0c4b1ed.tar.bz2
gentoo-8653e35b0d514f667684a8ea3d106f08a0c4b1ed.zip
dev-php/PEAR-File: Revbump adding tests, EAPI and eclass changes
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-File/PEAR-File-1.4.1-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-php/PEAR-File/PEAR-File-1.4.1-r1.ebuild b/dev-php/PEAR-File/PEAR-File-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..e8b7c9181ee8
--- /dev/null
+++ b/dev-php/PEAR-File/PEAR-File-1.4.1-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Common file and directory routines"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+src_test() {
+ peardev run-tests -r tests || die
+}