summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-08-14 10:04:28 -0400
committerBrian Evans <grknight@gentoo.org>2017-08-14 11:00:47 -0400
commit25ef3a56775fe54c7181dc319733e6a9567c20bf (patch)
treed8d559b9b2efdbfecb6e8f7ba988890960e9d7b4 /dev-php
parentbase/use.{,stable.}mask: Initial masks for php_targets_php7-2 slot (diff)
downloadgentoo-25ef3a56775fe54c7181dc319733e6a9567c20bf.tar.gz
gentoo-25ef3a56775fe54c7181dc319733e6a9567c20bf.tar.bz2
gentoo-25ef3a56775fe54c7181dc319733e6a9567c20bf.zip
dev-php/pecl-redis: Version bump wrt bug 627818
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-redis/Manifest1
-rw-r--r--dev-php/pecl-redis/pecl-redis-3.1.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
index e28e3aa6d178..150d813c30e8 100644
--- a/dev-php/pecl-redis/Manifest
+++ b/dev-php/pecl-redis/Manifest
@@ -1 +1,2 @@
DIST redis-3.1.2.tgz 199041 SHA256 a7687d007e48bef92049b8f53b425244d663da57d6b646d139248839e01f4ea3 SHA512 14b6321072f8ab41b8293b40ea8e1e2bdac1bb694c4566467ea4e6ced37c8fc41bf5712bd27cebf509f25fda0492765cd2c8d2fe61395bcb0b0d9cbbceebe684 WHIRLPOOL c619f04d6392ad4d81e3f41c83dce4f92c932805bbf7f418e8caa963744cedfaa03e6fb3433eec308da188577aa7fac4d1e35a14175f01c2f6d83571ce8f35a4
+DIST redis-3.1.3.tgz 196180 SHA256 92907f40bdd8d56607ba5c1593289c34c08f7dae460bd05e79603a4247b6cbf6 SHA512 269a45675e9547fdeebf9d9a1a36e6f75d6f9913ffc1069d0fc2a7f1a5d88ff4fb9f38693f488469339c2a7bfdfd81df102de5e12656e0662af166f874fc5fac WHIRLPOOL 2fb1419ac13aa7aeb20467270b8fdfe3d37b1c91c95da15db1733e81602fdaf9137c98319ab8784321c4c0d5cf69702c145d72e8bc6cfbf49c7a937de8a937ba
diff --git a/dev-php/pecl-redis/pecl-redis-3.1.3.ebuild b/dev-php/pecl-redis/pecl-redis-3.1.3.ebuild
new file mode 100644
index 000000000000..3c2df8c79d47
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-3.1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="redis"
+USE_PHP="php5-6 php7-0 php7-1"
+DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="igbinary +session"
+
+DEPEND="igbinary? (
+ php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] )
+ php_targets_php7-0? ( dev-php/igbinary[php_targets_php7-0] )
+ php_targets_php7-1? ( dev-php/igbinary[php_targets_php7-1] ) )"
+RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable session redis-session)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test(){
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}