summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/securimage
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/securimage')
-rw-r--r--dev-php/securimage/Manifest1
-rw-r--r--dev-php/securimage/metadata.xml8
-rw-r--r--dev-php/securimage/securimage-3.0.1.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/securimage/Manifest b/dev-php/securimage/Manifest
new file mode 100644
index 000000000000..9ede2af43306
--- /dev/null
+++ b/dev-php/securimage/Manifest
@@ -0,0 +1 @@
+DIST securimage-3.0.1.tar.gz 1107713 SHA256 f507c4e11c753cb40d6c3703ee513048a51b28ee85f4ab85f199d77d8013433a SHA512 e294a32302a04b0cf379475c44c3d9c28bc6cecd3196b10e6dc8dabbfb0f96f267f9d649f884ae1f583b4a8be9c2282a21514a6abf786f698feb9de36d9d3aa2 WHIRLPOOL 8e2d08b7e2130e830d36477f5c2b79685550882a811a36de655a120e0f6d6858fba73c53bfbff05c0cb824373151fab6cb1c92a000647be0c61d31598bbae462
diff --git a/dev-php/securimage/metadata.xml b/dev-php/securimage/metadata.xml
new file mode 100644
index 000000000000..548448307c18
--- /dev/null
+++ b/dev-php/securimage/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/securimage/securimage-3.0.1.ebuild b/dev-php/securimage/securimage-3.0.1.ebuild
new file mode 100644
index 000000000000..19984a9cd495
--- /dev/null
+++ b/dev-php/securimage/securimage-3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="PHP captcha creator and validator library"
+HOMEPAGE="http://phpcaptcha.org/"
+SRC_URI="http://phpcaptcha.org/${P}.tar.gz
+ ftp://mirror.ohnopub.net/mirror/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[gd,truetype]
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+src_install()
+{
+ # Grab all PHP files except the examples.
+ set *.php
+ local php_files=${@/*example*/}
+
+ insinto /usr/share/php/${PN}
+ doins -r ${php_files} *.{ttf,swf} audio backgrounds database images words
+
+ dodoc README* *example*
+}