summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:18:02 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:21:17 -0500
commitbe3acfa0bb749805cc28cf4fed380c4a78a04a37 (patch)
treebe0bf94a818270e07ecdc3bef40be7db44a97406 /dev-php/sebastian-recursion-context/sebastian-recursion-context-2.0.0.ebuild
parentdev-php/sebastian-resource-operations: New package for an unbundled phpunit (diff)
downloadgentoo-be3acfa0bb749805cc28cf4fed380c4a78a04a37.tar.gz
gentoo-be3acfa0bb749805cc28cf4fed380c4a78a04a37.tar.bz2
gentoo-be3acfa0bb749805cc28cf4fed380c4a78a04a37.zip
dev-php/sebastian-recursion-context: New package for an unbundled phpunit
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php/sebastian-recursion-context/sebastian-recursion-context-2.0.0.ebuild')
-rw-r--r--dev-php/sebastian-recursion-context/sebastian-recursion-context-2.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/sebastian-recursion-context/sebastian-recursion-context-2.0.0.ebuild b/dev-php/sebastian-recursion-context/sebastian-recursion-context-2.0.0.ebuild
new file mode 100644
index 000000000000..0f4ea3a96a8d
--- /dev/null
+++ b/dev-php/sebastian-recursion-context/sebastian-recursion-context-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Recursively process PHP variables"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/RecursionContext
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}