summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-01-21 09:34:15 -0500
committerBrian Evans <grknight@gentoo.org>2021-01-21 09:34:15 -0500
commit62456163577a6ec8302618b46e49d7a5c6b49a04 (patch)
tree7cb29c1f72faafc40c239be76cf9ecfae7c97dce /dev-php/pecl-xdiff/pecl-xdiff-2.1.0_pre.ebuild
parentdev-util/cppunit: add subslot (diff)
downloadgentoo-62456163577a6ec8302618b46e49d7a5c6b49a04.tar.gz
gentoo-62456163577a6ec8302618b46e49d7a5c6b49a04.tar.bz2
gentoo-62456163577a6ec8302618b46e49d7a5c6b49a04.zip
dev-php/pecl-xdiff: Pre-release version bump for PHP 8 support
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-xdiff/pecl-xdiff-2.1.0_pre.ebuild')
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-2.1.0_pre.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-2.1.0_pre.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-2.1.0_pre.ebuild
new file mode 100644
index 000000000000..336f7f480f72
--- /dev/null
+++ b/dev-php/pecl-xdiff/pecl-xdiff-2.1.0_pre.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_NAME="xdiff"
+PHP_EXT_PECL_PKG="xdiff"
+DOCS=( README.API )
+
+USE_PHP="php7-3 php7-4 php8-0"
+PHP_EXT_PECL_FILENAME="${PN/pecl-/}-2.0.1.tgz"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension for generating diff files"
+LICENSE="PHP-3.01"
+SLOT="7"
+
+DEPEND="dev-libs/libxdiff"
+RDEPEND="${DEPEND}"
+PHP_EXT_ECONF_ARGS=()
+PATCHES=(
+"${FILESDIR}/2.1.0_pre-php8.patch"
+"${FILESDIR}/2.1.0_pre-php8-2.patch"
+"${FILESDIR}/2.1.0_pre-php8-3.patch"
+)
+S="${WORKDIR}/${PHP_EXT_PECL_FILENAME/.tgz/}"
+PHP_EXT_S="${S}"