summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-01-11 10:33:44 -0500
committerBrian Evans <grknight@gentoo.org>2021-01-11 10:35:13 -0500
commitbcff1510bc9e0dd3e376ac86c3742a30f95ecbdb (patch)
tree03a113a7c80c6625aa9ee2557eb7af54a5ef646e /dev-php/pecl-rrd
parentmedia-gfx/gimp: 2.10.22 add fix autoconf-2.70 compatibility (diff)
downloadgentoo-bcff1510bc9e0dd3e376ac86c3742a30f95ecbdb.tar.gz
gentoo-bcff1510bc9e0dd3e376ac86c3742a30f95ecbdb.tar.bz2
gentoo-bcff1510bc9e0dd3e376ac86c3742a30f95ecbdb.zip
dev-php/pecl-rrd: Revbump for upstream patches and target change
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-rrd')
-rw-r--r--dev-php/pecl-rrd/files/2.0.1/0001-arginfo.patch81
-rw-r--r--dev-php/pecl-rrd/files/2.0.1/0002-relax-float-test-result.patch132
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r4.ebuild29
3 files changed, 242 insertions, 0 deletions
diff --git a/dev-php/pecl-rrd/files/2.0.1/0001-arginfo.patch b/dev-php/pecl-rrd/files/2.0.1/0001-arginfo.patch
new file mode 100644
index 000000000000..28496fe19c96
--- /dev/null
+++ b/dev-php/pecl-rrd/files/2.0.1/0001-arginfo.patch
@@ -0,0 +1,81 @@
+--- a/rrd.c 2020/09/23 07:41:40 350617
++++ b/rrd.c 2020/09/23 09:09:08 350618
+@@ -552,6 +552,9 @@
+ ZEND_ARG_INFO(0, file)
+ ZEND_ARG_INFO(0, options)
+ ZEND_END_ARG_INFO()
++
++ZEND_BEGIN_ARG_INFO(arginfo_rrd_void, 0)
++ZEND_END_ARG_INFO()
+ /* }}} */
+
+ /* {{{ */
+@@ -559,7 +562,7 @@
+ PHP_FE(rrd_update, arginfo_rrd_update)
+ PHP_FE(rrd_create, arginfo_rrd_create)
+ PHP_FE(rrd_graph, arginfo_rrd_graph)
+- PHP_FE(rrd_error, NULL)
++ PHP_FE(rrd_error, arginfo_rrd_void)
+ PHP_FE(rrd_fetch, arginfo_rrd_fetch)
+ PHP_FE(rrd_first, arginfo_rrd_first)
+ PHP_FE(rrd_info, arginfo_rrd_info)
+@@ -569,9 +572,9 @@
+ PHP_FE(rrd_tune, arginfo_rrd_tune)
+ PHP_FE(rrd_xport, arginfo_rrd_xport)
+ #ifdef HAVE_RRDC_DISCONNECT
+- PHP_FE(rrdc_disconnect, NULL)
++ PHP_FE(rrdc_disconnect, arginfo_rrd_void)
+ #endif
+- PHP_FE(rrd_version, NULL)
++ PHP_FE(rrd_version, arginfo_rrd_void)
+ PHP_FE_END
+ };
+ /* }}} */
+--- a/rrd_create.c 2020/09/23 07:41:40 350617
++++ b/rrd_create.c 2020/09/23 09:09:08 350618
+@@ -323,10 +323,13 @@
+ ZEND_ARG_INFO(0, description)
+ ZEND_END_ARG_INFO()
+
++ZEND_BEGIN_ARG_INFO_EX(arginfo_rrdcreator_void, 0, 0, 0)
++ZEND_END_ARG_INFO()
++
+ /* class method table */
+ static zend_function_entry rrd_create_methods[] = {
+ PHP_ME(RRDCreator, __construct, arginfo_rrdcreator_construct, ZEND_ACC_PUBLIC)
+- PHP_ME(RRDCreator, save, NULL, ZEND_ACC_PUBLIC)
++ PHP_ME(RRDCreator, save, arginfo_rrdcreator_void, ZEND_ACC_PUBLIC)
+ PHP_ME(RRDCreator, addDataSource, arginfo_rrdcreator_description, ZEND_ACC_PUBLIC)
+ PHP_ME(RRDCreator, addArchive, arginfo_rrdcreator_description, ZEND_ACC_PUBLIC)
+ PHP_FE_END
+--- a/rrd_graph.c 2020/09/23 07:41:40 350617
++++ b/rrd_graph.c 2020/09/23 09:09:08 350618
+@@ -140,6 +140,7 @@
+ array_init(&zv_argv);
+
+ ZEND_HASH_FOREACH_KEY_VAL(Z_ARRVAL(obj->zv_arr_options), num_key, zs_key, zv_option_val) {
++ (void)num_key; /* to avoid -Wunused-but-set-variable */
+ smart_string option = {0}; /* one argument option */
+
+ /* option with string key means long option, hence they are used as
+@@ -356,6 +357,9 @@
+ /* }}} */
+
+ /* arguments */
++ZEND_BEGIN_ARG_INFO_EX(arginfo_rrd_void, 0, 0, 0)
++ZEND_END_ARG_INFO()
++
+ ZEND_BEGIN_ARG_INFO_EX(arginfo_rrd_path, 0, 0, 1)
+ ZEND_ARG_INFO(0, path)
+ ZEND_END_ARG_INFO()
+@@ -367,8 +371,8 @@
+ /* class method table */
+ static zend_function_entry rrd_graph_methods[] = {
+ PHP_ME(RRDGraph, __construct, arginfo_rrd_path, ZEND_ACC_PUBLIC)
+- PHP_ME(RRDGraph, save, NULL, ZEND_ACC_PUBLIC)
+- PHP_ME(RRDGraph, saveVerbose, NULL, ZEND_ACC_PUBLIC)
++ PHP_ME(RRDGraph, save, arginfo_rrd_void, ZEND_ACC_PUBLIC)
++ PHP_ME(RRDGraph, saveVerbose, arginfo_rrd_void, ZEND_ACC_PUBLIC)
+ PHP_ME(RRDGraph, setOptions, arginfo_rrd_options, ZEND_ACC_PUBLIC)
+ PHP_FE_END
+ };
diff --git a/dev-php/pecl-rrd/files/2.0.1/0002-relax-float-test-result.patch b/dev-php/pecl-rrd/files/2.0.1/0002-relax-float-test-result.patch
new file mode 100644
index 000000000000..b4a692fc3f5f
--- /dev/null
+++ b/dev-php/pecl-rrd/files/2.0.1/0002-relax-float-test-result.patch
@@ -0,0 +1,132 @@
+--- a/tests/rrd_010.phpt 2020/09/23 07:41:40 350617
++++ b/tests/rrd_010.phpt 2020/09/23 09:09:08 350618
+@@ -40,11 +40,11 @@
+ [920805900]=>
+ float(0)
+ [920806200]=>
+- float(0.033333333333333)
++ float(0.03333333333%s)
+ [920806500]=>
+- float(0.033333333333333)
++ float(0.03333333333%s)
+ [920806800]=>
+- float(0.033333333333333)
++ float(0.03333333333%s)
+ [920807100]=>
+ float(0.02)
+ [920807400]=>
+@@ -52,20 +52,20 @@
+ [920807700]=>
+ float(0.02)
+ [920808000]=>
+- float(0.013333333333333)
++ float(0.01333333333%s)
+ [920808300]=>
+- float(0.016666666666667)
++ float(0.01666666666%s)
+ }
+ ["speed2"]=>
+ array(13) {
+ [920804700]=>
+ float(NAN)
+ [920805000]=>
+- float(0.056666666666667)
++ float(0.05666666666%s)
+ [920805300]=>
+ float(0.02)
+ [920805600]=>
+- float(0.0033333333333333)
++ float(0.00333333333%s)
+ [920805900]=>
+ float(0)
+ [920806200]=>
+@@ -73,7 +73,7 @@
+ [920806500]=>
+ float(0)
+ [920806800]=>
+- float(0.066666666666667)
++ float(0.06666666666%s)
+ [920807100]=>
+ float(0.02)
+ [920807400]=>
+@@ -81,9 +81,9 @@
+ [920807700]=>
+ float(0.02)
+ [920808000]=>
+- float(0.013333333333333)
++ float(0.01333333333%s)
+ [920808300]=>
+- float(0.016666666666667)
++ float(0.01666666666%s)
+ }
+ }
+-}
+\ No newline at end of file
++}
+--- a/tests/rrd_012.phpt 2020/09/23 07:41:40 350617
++++ b/tests/rrd_012.phpt 2020/09/23 09:09:08 350618
+@@ -69,7 +69,7 @@
+ ["rra[1].xff"]=>
+ float(0.5)
+ ["rra[1].cdp_prep[0].value"]=>
+- float(0.026666666666667)
++ float(0.02666666666%s)
+ ["rra[1].cdp_prep[0].unknown_datapoints"]=>
+ int(0)
+ }
+--- a/tests/rrd_017.phpt 2020/09/23 07:41:40 350617
++++ b/tests/rrd_017.phpt 2020/09/23 09:09:08 350618
+@@ -47,11 +47,11 @@
+ [920805900]=>
+ float(0)
+ [920806200]=>
+- float(0.033333333333333)
++ float(0.0333333333%s)
+ [920806500]=>
+- float(0.033333333333333)
++ float(0.0333333333%s)
+ [920806800]=>
+- float(0.033333333333333)
++ float(0.0333333333%s)
+ [920807100]=>
+ float(0.02)
+ [920807400]=>
+@@ -59,9 +59,9 @@
+ [920807700]=>
+ float(0.02)
+ [920808000]=>
+- float(0.013333333333333)
++ float(0.0133333333%s)
+ [920808300]=>
+- float(0.016666666666667)
++ float(0.0166666666%s)
+ }
+ }
+ [1]=>
+@@ -81,11 +81,11 @@
+ [920805900]=>
+ float(0)
+ [920806200]=>
+- float(33.333333333333)
++ float(33.333333333%s)
+ [920806500]=>
+- float(33.333333333333)
++ float(33.333333333%s)
+ [920806800]=>
+- float(33.333333333333)
++ float(33.333333333%s)
+ [920807100]=>
+ float(20)
+ [920807400]=>
+@@ -93,9 +93,9 @@
+ [920807700]=>
+ float(20)
+ [920808000]=>
+- float(13.333333333333)
++ float(13.333333333%s)
+ [920808300]=>
+- float(16.666666666667)
++ float(16.666666666%s)
+ }
+ }
+ }
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r4.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r4.ebuild
new file mode 100644
index 000000000000..7652ef702136
--- /dev/null
+++ b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="RRDtool bindings for PHP"
+LICENSE="BSD"
+SLOT="7"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-analyzer/rrdtool[graph(-)]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}" )
+PHP_EXT_ECONF_ARGS=()
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Prepare test data
+ emake -C tests/data all
+ NO_INTERACTION="yes" emake test
+ done
+}