summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-10 10:59:18 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-10 11:34:07 -0400
commitbe176d72b5c2b69a186e014d16be6f2e5423af2b (patch)
tree910807d8bc6de0d7ebac88d624156702d8b7f623 /dev-php/onphp/onphp-1.0.11_pre20141124.ebuild
parentsys-block/storcli: Bump to v1.23.02 (diff)
downloadgentoo-be176d72b5c2b69a186e014d16be6f2e5423af2b.tar.gz
gentoo-be176d72b5c2b69a186e014d16be6f2e5423af2b.tar.bz2
gentoo-be176d72b5c2b69a186e014d16be6f2e5423af2b.zip
dev-php/onphp: Add new github snapshot with updated EAPI and Homepage
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php/onphp/onphp-1.0.11_pre20141124.ebuild')
-rw-r--r--dev-php/onphp/onphp-1.0.11_pre20141124.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/onphp/onphp-1.0.11_pre20141124.ebuild b/dev-php/onphp/onphp-1.0.11_pre20141124.ebuild
new file mode 100644
index 000000000000..7c375a214679
--- /dev/null
+++ b/dev-php/onphp/onphp-1.0.11_pre20141124.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vcs-snapshot
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework"
+HOMEPAGE="https://github.com/onPHP/onphp-framework/"
+SRC_URI="https://github.com/onPHP/onphp-framework/archive/706ddd5a2a33bd65a13c4e3ec8c46c5ce700133c.tar.gz -> ${P}.tar.gz
+ doc? ( http://onphp.org/download/${PN}-api-1.0.10.tar.bz2 )
+"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+
+src_install() {
+ rm doc/LICENSE || die
+ dodoc $(find doc -maxdepth 1 -type f -print)
+ if use doc ; then
+ local HTML_DOCS=( "${WORKDIR}/${PN}-api-1.0.10/" )
+ einstalldocs
+ fi
+ insinto "/usr/share/php/${PN}"
+ doins global.inc.php.tpl
+ doins -r core main meta
+}