summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2017-03-31 15:46:14 +0200
committerMichael Orlitzky <mjo@gentoo.org>2017-04-25 11:14:42 -0400
commitf7d3914fd79f06f5e0820e453054a127c0f52211 (patch)
treea8a44105eb2498d5e1c68c76c55258d35ee69647 /dev-php/jsonlint/jsonlint-1.6.0.ebuild
parentdev-python/certifi: Version bump to 2017.4.17 (diff)
downloadgentoo-f7d3914fd79f06f5e0820e453054a127c0f52211.tar.gz
gentoo-f7d3914fd79f06f5e0820e453054a127c0f52211.tar.bz2
gentoo-f7d3914fd79f06f5e0820e453054a127c0f52211.zip
dev-php/jsonlint: Add version bump 1.6.0
Add version bump 1.6.0 Gentoo-Bug: 613898
Diffstat (limited to 'dev-php/jsonlint/jsonlint-1.6.0.ebuild')
-rw-r--r--dev-php/jsonlint/jsonlint-1.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/jsonlint/jsonlint-1.6.0.ebuild b/dev-php/jsonlint/jsonlint-1.6.0.ebuild
new file mode 100644
index 000000000000..ea1e8f975dc1
--- /dev/null
+++ b/dev-php/jsonlint/jsonlint-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="JSON Lint for PHP"
+HOMEPAGE="https://github.com/Seldaek/jsonlint"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ sed -i -e "s:__DIR__:'${S}/src/Seld/JsonLint':" "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Seld/JsonLint"
+ doins -r src/Seld/JsonLint/. "${FILESDIR}"/autoload.php
+ dodoc README.mdown
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}