summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-11-01 18:56:08 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-11-01 21:03:18 -0400
commite0d965119406e992caa8bbf4ba33da23a43d1652 (patch)
tree351b144e2c50f894f27bb610e94584510009c98d /dev-php/composer/composer-1.5.2-r1.ebuild
parentdev-php/composer: bump to 1.5.2 (diff)
downloadgentoo-e0d965119406e992caa8bbf4ba33da23a43d1652.tar.gz
gentoo-e0d965119406e992caa8bbf4ba33da23a43d1652.tar.bz2
gentoo-e0d965119406e992caa8bbf4ba33da23a43d1652.zip
dev-php/composer: bump the lower bound on dev-php/json-schema to v3.0.0.
The package.json file for composer says that json-schema v3, v4, or v5 are all good. The lower (inclusive) bound in the ebuild was v2, so it has been updated to >=3.0.0. Thanks to Guillaume Seren for noticing. Closes: https://github.com/gentoo/gentoo/pull/6099 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-php/composer/composer-1.5.2-r1.ebuild')
-rw-r--r--dev-php/composer/composer-1.5.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-php/composer/composer-1.5.2-r1.ebuild b/dev-php/composer/composer-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..7e9f959246d2
--- /dev/null
+++ b/dev-php/composer/composer-1.5.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*[curl]
+ >=dev-php/ca-bundle-1.0.0
+ >=dev-php/cli-prompt-1.0.0
+ >=dev-php/psr-log-1.0.2
+ dev-php/fedora-autoloader
+ >=dev-php/json-schema-3.0.0
+ >=dev-php/jsonlint-1.4.0
+ >=dev-php/phar-utils-1.0.0
+ >=dev-php/semver-1.0.0
+ >=dev-php/spdx-licenses-1.0.0
+ >=dev-php/symfony-console-2.7.9
+ >=dev-php/symfony-filesystem-2.7.20
+ >=dev-php/symfony-finder-2.7.20
+ >=dev-php/symfony-process-2.8.12"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+
+ # Composer expects the LICENSE file to be there, and the
+ # easiest thing to do is to give it what it wants.
+ doins -r src res LICENSE
+
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}"/autoload.php
+
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ dosym "/usr/share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ dodoc CHANGELOG.md README.md doc/*.md
+ dodoc -r doc/articles doc/faqs
+}