summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-08 16:19:06 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-08 16:19:24 -0500
commitdaa4e363de35674dd6a814ae176799e42d26ee93 (patch)
tree06aa96785c69e14dd44383c335c06854a9b179fd /dev-php/PEAR-Text_Figlet/PEAR-Text_Figlet-1.0.2-r1.ebuild
parentapp-emulation/rkt: remove old versions (diff)
downloadgentoo-daa4e363de35674dd6a814ae176799e42d26ee93.tar.gz
gentoo-daa4e363de35674dd6a814ae176799e42d26ee93.tar.bz2
gentoo-daa4e363de35674dd6a814ae176799e42d26ee93.zip
dev-php/PEAR-Text_Figlet: new EAPI=6 revision sans the php-pear-r1 eclass.
This new revision updates to EAPI=6, and drops the php-pear-r1 eclass. Dropping an eclass is motivation in itself, but along with that reduction in complexity comes a fix: we now install the documentation and examples in the correct place. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/PEAR-Text_Figlet/PEAR-Text_Figlet-1.0.2-r1.ebuild')
-rw-r--r--dev-php/PEAR-Text_Figlet/PEAR-Text_Figlet-1.0.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Figlet/PEAR-Text_Figlet-1.0.2-r1.ebuild b/dev-php/PEAR-Text_Figlet/PEAR-Text_Figlet-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..0e720f28449a
--- /dev/null
+++ b/dev-php/PEAR-Text_Figlet/PEAR-Text_Figlet-1.0.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Render text using FIGlet fonts"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01
+ examples? ( GPL-2+ OFL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc docs/README.TXT
+
+ if use examples; then
+ dodoc -r docs/examples
+
+ # Earlier versions of this ebuild installed this font under
+ # /usr/share/php/data, which is obviously the wrong place for
+ # them, but is where we have configured PEAR's data_dir. The
+ # fonts can be referenced by absolute path, however, and not
+ # just by name. Since this font is used in the example -- and as
+ # long as no one expects this *particular* font to work out of
+ # the box -- installing it with the docs will suffice.
+ #
+ # The one consumer of this in the tree is PEAR-Text_CAPTCHA, and
+ # it loads its fonts using an absolute path.
+ dodoc fonts/makisupa.flf
+ fi
+
+ insinto /usr/share/php
+ doins -r Text
+}