summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/PEAR-Net_Server
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/PEAR-Net_Server')
-rw-r--r--dev-php/PEAR-Net_Server/Manifest2
-rw-r--r--dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2-r1.ebuild23
-rw-r--r--dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild23
-rw-r--r--dev-php/PEAR-Net_Server/metadata.xml5
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_Server/Manifest b/dev-php/PEAR-Net_Server/Manifest
new file mode 100644
index 000000000000..f4ae8f348258
--- /dev/null
+++ b/dev-php/PEAR-Net_Server/Manifest
@@ -0,0 +1,2 @@
+DIST Net_Server-1.0.2.tgz 17280 SHA256 efa1cf43ba7fc1acedf0ed5e47556569bc2c9a75d73a43a085818f75f86e58ff SHA512 9ac919bcf5c737529361608c86b31ec1037cdb7166f805330a3747f4857a0f5919b792a93a74b652a505821b15ebe7e9493ffddb2213ce32669d68d9de178e9f WHIRLPOOL 78851bae10ce8a42c45b57da09112d85cbdbab9002dba911a69698abe0ef43fdf3cf21ce7248ba5939ed9ec4595ff0a0030f5a7cc2bc3045f2240221eef70ded
+DIST Net_Server-1.0.3.tgz 17666 SHA256 794f88a2ad5d5dd58d4e7ef42d4ee5eb1582a3a75538f66af2fa4a1125bb91bd SHA512 8106f46ecbc4c567cff9816c7d0ba7e0dab15215b9725f8b1fa3112276356137b4ae5e1159758743030406fab301c76b64c7954f3cc8bf8e662c33a015532db4 WHIRLPOOL 62b8d1c334c9fcdcfe95254899744b36eb88697517d1f29c608c25a89a0a9f9031cb50faf984c79ea6ba4e5d0f4013c1be1dfa095cfa1bf7b7743f79ef450bab
diff --git a/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2-r1.ebuild b/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..308a7f2782c7
--- /dev/null
+++ b/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit php-pear-r1
+
+DESCRIPTION="Generic server class for PHP"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[sockets]"
+
+pkg_postinst() {
+ if ! has_version "dev-lang/php[pcntl]" ; then
+ elog "${PN} can optionally use dev-lang/php pcntl features."
+ elog "If you want those, recompile dev-lang/php with this flag in USE."
+ fi
+}
diff --git a/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild b/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild
new file mode 100644
index 000000000000..308a7f2782c7
--- /dev/null
+++ b/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit php-pear-r1
+
+DESCRIPTION="Generic server class for PHP"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[sockets]"
+
+pkg_postinst() {
+ if ! has_version "dev-lang/php[pcntl]" ; then
+ elog "${PN} can optionally use dev-lang/php pcntl features."
+ elog "If you want those, recompile dev-lang/php with this flag in USE."
+ fi
+}
diff --git a/dev-php/PEAR-Net_Server/metadata.xml b/dev-php/PEAR-Net_Server/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php/PEAR-Net_Server/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>