summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-08-02 16:43:28 -0400
committerBrian Evans <grknight@gentoo.org>2017-08-02 16:43:28 -0400
commit0cf3eeaee0d5c6ef0fe7e2fed36ec53fc6f8a310 (patch)
tree9196720b9f4ba32d62f30b735f5c4c9976331663 /dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild
parentdev-libs/amdgpu-pro-opencl: bump to 17.30-458935 (diff)
downloadgentoo-0cf3eeaee0d5c6ef0fe7e2fed36ec53fc6f8a310.tar.gz
gentoo-0cf3eeaee0d5c6ef0fe7e2fed36ec53fc6f8a310.tar.bz2
gentoo-0cf3eeaee0d5c6ef0fe7e2fed36ec53fc6f8a310.zip
dev-php/PEAR-DB: Revbump for new EAPI and eclass; Drop old
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild')
-rw-r--r--dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild b/dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild
new file mode 100644
index 000000000000..ef5e7305e352
--- /dev/null
+++ b/dev-php/PEAR-DB/PEAR-DB-1.9.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="Database abstraction layer for PHP"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+DOCS=( doc/TESTERS doc/IDEAS doc/MAINTAINERS doc/STATUS )
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR, and also
+ # a working version of the cli SAPI eselected.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}