summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-11-20 08:57:05 -0500
committerBrian Evans <grknight@gentoo.org>2020-11-20 08:57:05 -0500
commita8cf5201eed5b8242807379bffa68d9755bd9728 (patch)
tree69eaa88d1a994f6d73b50d5528aafdc215f8c1b5 /dev-php/PEAR-Archive_Tar
parentdev-python/python-systemd: arm64 keyworded (bug #754780) (diff)
downloadgentoo-a8cf5201eed5b8242807379bffa68d9755bd9728.tar.gz
gentoo-a8cf5201eed5b8242807379bffa68d9755bd9728.tar.bz2
gentoo-a8cf5201eed5b8242807379bffa68d9755bd9728.zip
dev-php/PEAR-Archive_Tar: Security bump for 1.4.11
Bug: https://bugs.gentoo.org/755653 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Archive_Tar')
-rw-r--r--dev-php/PEAR-Archive_Tar/Manifest1
-rw-r--r--dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.11.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/PEAR-Archive_Tar/Manifest b/dev-php/PEAR-Archive_Tar/Manifest
index 4aeaf6a7af59..7084a6282408 100644
--- a/dev-php/PEAR-Archive_Tar/Manifest
+++ b/dev-php/PEAR-Archive_Tar/Manifest
@@ -1 +1,2 @@
DIST Archive_Tar-1.4.10.tgz 21481 BLAKE2B d6658f344baee4c70aedc7c8e59d8e4e481a5c2fbd72920d65943e2d9cf3a6d955a77c62c58fe3391a9250206f105d96b2cf186cefd13a261269d29b27722350 SHA512 265a00b0e71e718a0a0f1f5640b2a95c3b5f3a62235477a22ef762109cb2f6dbdaa0319f2f5aed5fdd9b4f52317bf761b3fcefd03a82c941e71e04c1a3e4d2a9
+DIST Archive_Tar-1.4.11.tgz 21556 BLAKE2B f7e450f4581400159099dba023192ec4026da8867c675119001085651c20315523a58180e0ccd4528e3b1764e222945055702e0fd8e42bb5976b891230351f29 SHA512 a67ff191eb1d814094fc752b58b5d4b4d3db0fd2476fce403f8e5cac49a35fd1219167817dc84d6f957af87d326435aef000e2e0b16357a0d051ab407b76d2cc
diff --git a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.11.ebuild b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.11.ebuild
new file mode 100644
index 000000000000..ec77b9463d55
--- /dev/null
+++ b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tar file management class"
+HOMEPAGE="https://pear.php.net/package/Archive_Tar"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+# bzip2 and zlib are needed for compressed tarballs, and there's one
+# call to preg_match to test paths against a pattern of files and
+# directories that will be ignored.
+RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
+PDEPEND="dev-php/PEAR-PEAR"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Archive
+
+ dodoc docs/*
+}