summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-08 13:42:15 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-08 13:42:15 +1200
commit351c91b9d63d1198d3e399985eab4e769f3b246f (patch)
treeac3a39fef640a79e52b263d79b099369c0b380e6 /dev-perl
parentdev-perl/CSS-Packer: Bump to version 2.70.0 (diff)
downloadgentoo-351c91b9d63d1198d3e399985eab4e769f3b246f.tar.gz
gentoo-351c91b9d63d1198d3e399985eab4e769f3b246f.tar.bz2
gentoo-351c91b9d63d1198d3e399985eab4e769f3b246f.zip
dev-perl/CSS-Squish: -r bump for EAPI7
- EAPI7 - Parallel tests - Strip useless tests - Add license note re bug https://bugs.gentoo.org/718946 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/CSS-Squish/CSS-Squish-0.100.0-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/CSS-Squish/CSS-Squish-0.100.0-r2.ebuild b/dev-perl/CSS-Squish/CSS-Squish-0.100.0-r2.ebuild
new file mode 100644
index 000000000000..969b95954aba
--- /dev/null
+++ b/dev-perl/CSS-Squish/CSS-Squish-0.100.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TSIBLEY
+DIST_VERSION=0.10
+inherit perl-module
+
+DESCRIPTION="Compact many CSS files into one big file"
+# License note: "perl 5.8.3 or later" bug https://bugs.gentoo.org/718946
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-File-Spec
+ virtual/perl-Scalar-List-Utils
+ dev-perl/URI
+"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-LongString
+ )
+"
+PERL_RM_FILES=(
+ "t/99-pod-coverage.t"
+ "t/99-pod.t"
+)