summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-26 16:41:28 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-26 16:41:28 +1300
commit82bcc3d96146082f0e5747e13dffc25feb75a3fc (patch)
treec1a5e10777e93fea1fe0a0f9bca5e82ebf3aec75 /dev-perl/indirect/indirect-0.370.0.ebuild
parentdev-perl/Inline-Python: Bump to version 0.560.0 (diff)
downloadgentoo-82bcc3d96146082f0e5747e13dffc25feb75a3fc.tar.gz
gentoo-82bcc3d96146082f0e5747e13dffc25feb75a3fc.tar.bz2
gentoo-82bcc3d96146082f0e5747e13dffc25feb75a3fc.zip
dev-perl/indirect: Bump to version 0.370.0
Upstream: - Refactor XS code - Fix intermitten segfaults with heredocs Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/indirect/indirect-0.370.0.ebuild')
-rw-r--r--dev-perl/indirect/indirect-0.370.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/indirect/indirect-0.370.0.ebuild b/dev-perl/indirect/indirect-0.370.0.ebuild
new file mode 100644
index 000000000000..0cef396e170c
--- /dev/null
+++ b/dev-perl/indirect/indirect-0.370.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=VPIT
+DIST_VERSION=0.37
+inherit perl-module
+
+DESCRIPTION="Lexically warn about using the indirect method call syntax"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Socket
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST="do parallel"