summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/gtk2-perl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/gtk2-perl')
-rw-r--r--dev-perl/gtk2-perl/Manifest2
-rw-r--r--dev-perl/gtk2-perl/gtk2-perl-1.247.0.ebuild35
-rw-r--r--dev-perl/gtk2-perl/gtk2-perl-1.249.500.ebuild36
-rw-r--r--dev-perl/gtk2-perl/metadata.xml23
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-perl/gtk2-perl/Manifest b/dev-perl/gtk2-perl/Manifest
new file mode 100644
index 000000000000..51e210c251cf
--- /dev/null
+++ b/dev-perl/gtk2-perl/Manifest
@@ -0,0 +1,2 @@
+DIST Gtk2-1.247.tar.gz 741467 SHA256 475bcb35d4a86e29d7bd7d870d81c68aae354947c1854d60f574a53faf2ae6aa SHA512 9c0fb510cfa806c1fe5bc06827130e245809a9b629442fb47a54100a95434bc4e11a7f2fd525463e467c037e60690d43c2fa79c03a2b4c063eb3627547306724 WHIRLPOOL 9aca1eabaa6b206969f77fcf0056f5561bc9795debc5d4a67459659cd4caa49afbb9609f9f4c596c2236b0340917bf2ecf389274279cb782af604dee69ccbdff
+DIST Gtk2-1.2495.tar.gz 743621 SHA256 6abcc772491f88308327e57f0de827b2abffd67ba677f2c82f291f893c9bfdd6 SHA512 07abfa2786d386f063282475ab5f6977ed034ab801e2e6ca06628b1828f7bee34675ee812bf0f4036bad74f648f8c0400099e4a8f92b194c83422bc2bdf58fa5 WHIRLPOOL 4b88475e79999348950bc6d6ee7fd7d0afc7eda1370e335003f928b14b21b3f66ab23f3b13142766f0b4e2fd3a246480abd30a7cd7273980d09d862adca6a534
diff --git a/dev-perl/gtk2-perl/gtk2-perl-1.247.0.ebuild b/dev-perl/gtk2-perl/gtk2-perl-1.247.0.ebuild
new file mode 100644
index 000000000000..3b2a55cefd32
--- /dev/null
+++ b/dev-perl/gtk2-perl/gtk2-perl-1.247.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=Gtk2
+MODULE_AUTHOR=XAOC
+MODULE_VERSION=1.247
+inherit perl-module
+#inherit virtualx
+
+DESCRIPTION="Perl bindings for GTK2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-perl/Cairo
+ >=dev-perl/glib-perl-1.280.0
+ >=dev-perl/Pango-1.220.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/extutils-pkgconfig-1.030.0
+"
+
+#RDEPEND+=" || ( <x11-libs/gtk+-2.22.1-r1[jpeg] x11-libs/gdk-pixbuf[jpeg] )"
+#SRC_TEST=do
+#src_test(){
+# Xemake -j1 test || die
+#}
diff --git a/dev-perl/gtk2-perl/gtk2-perl-1.249.500.ebuild b/dev-perl/gtk2-perl/gtk2-perl-1.249.500.ebuild
new file mode 100644
index 000000000000..8e28c010e68b
--- /dev/null
+++ b/dev-perl/gtk2-perl/gtk2-perl-1.249.500.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=Gtk2
+MODULE_AUTHOR=XAOC
+MODULE_VERSION=1.2495
+inherit perl-module
+#inherit virtualx
+
+DESCRIPTION="Perl bindings for GTK2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gtk+:2
+ >=dev-perl/Cairo-1
+ >=dev-perl/glib-perl-1.280.0
+ >=dev-perl/Pango-1.220.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/extutils-pkgconfig-1.030.0
+"
+
+#RDEPEND+=" || ( <x11-libs/gtk+-2.22.1-r1[jpeg] x11-libs/gdk-pixbuf[jpeg] )"
+#SRC_TEST=do
+#src_test(){
+# Xemake -j1 test || die
+#}
diff --git a/dev-perl/gtk2-perl/metadata.xml b/dev-perl/gtk2-perl/metadata.xml
new file mode 100644
index 000000000000..535a9aa80266
--- /dev/null
+++ b/dev-perl/gtk2-perl/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Gtk2</remote-id>
+ <remote-id type="cpan-module">Gtk2</remote-id>
+ <remote-id type="cpan-module">Gtk2::Builder</remote-id>
+ <remote-id type="cpan-module">Gtk2::CellLayout::DataFunc</remote-id>
+ <remote-id type="cpan-module">Gtk2::CodeGen</remote-id>
+ <remote-id type="cpan-module">Gtk2::Gdk</remote-id>
+ <remote-id type="cpan-module">Gtk2::Gdk::Atom</remote-id>
+ <remote-id type="cpan-module">Gtk2::Helper</remote-id>
+ <remote-id type="cpan-module">Gtk2::Pango</remote-id>
+ <remote-id type="cpan-module">Gtk2::SimpleList</remote-id>
+ <remote-id type="cpan-module">Gtk2::SimpleList::TiedList</remote-id>
+ <remote-id type="cpan-module">Gtk2::SimpleList::TiedRow</remote-id>
+ <remote-id type="cpan-module">Gtk2::SimpleMenu</remote-id>
+ <remote-id type="cpan-module">Gtk2::TestHelper</remote-id>
+ <remote-id type="cpan-module">Gtk2::TreeModelSort</remote-id>
+ <remote-id type="cpan-module">Gtk2::TreeSortable::IterCompareFunc</remote-id>
+ </upstream>
+</pkgmetadata>