summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-15 00:03:44 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-16 21:25:55 +0200
commit180a2ec62f01d9cde38131525ee996ed01819a94 (patch)
tree8d3eead936f57d7af06c84176037a6c74f186b1b /dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild
parentRevert "ssl-cert.eclass: add libressl support" (diff)
downloadgentoo-180a2ec62f01d9cde38131525ee996ed01819a94.tar.gz
gentoo-180a2ec62f01d9cde38131525ee996ed01819a94.tar.bz2
gentoo-180a2ec62f01d9cde38131525ee996ed01819a94.zip
dev-perl/Test-Mock-LWP-Dispatch: Bump to version 0.80.0
- EAPI6 - Cleanup tests - Fix missing deps - Cleanup metadata Upstream: - Add map_passthrough method Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild')
-rw-r--r--dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild b/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild
new file mode 100644
index 000000000000..6b735ed3a44c
--- /dev/null
+++ b/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=TADAM
+DIST_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Mocks LWP::UserAgent and dispatches your requests/responses"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ virtual/perl-Exporter
+ dev-perl/HTTP-Message
+ dev-perl/libwww-perl
+ dev-perl/Test-MockObject
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Exception
+ )
+"
+src_test() {
+ perl_rm_files t/release-pod-coverage.t t/release-pod-syntax.t
+ perl-module_src_test
+}