summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Test-DistManifest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Test-DistManifest')
-rw-r--r--dev-perl/Test-DistManifest/Manifest2
-rw-r--r--dev-perl/Test-DistManifest/Test-DistManifest-1.12.0-r1.ebuild26
-rw-r--r--dev-perl/Test-DistManifest/Test-DistManifest-1.14.0.ebuild31
-rw-r--r--dev-perl/Test-DistManifest/metadata.xml12
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-perl/Test-DistManifest/Manifest b/dev-perl/Test-DistManifest/Manifest
new file mode 100644
index 000000000000..6b772f4b08fb
--- /dev/null
+++ b/dev-perl/Test-DistManifest/Manifest
@@ -0,0 +1,2 @@
+DIST Test-DistManifest-1.012.tar.gz 17700 SHA256 4b128bef9beea2f03bdca037ceb722de43b4a2c516c3f50c2a26421548a72208 SHA512 5cb4de5808a451ae927466fd0cd8127cba22e3fa80862070499733ef504bfe9418b10d76e83a75e1908c74ad5efb7ef3f17c8432dd3505c394520aaba03646a9 WHIRLPOOL 73f215ca11b1814a224ce24e33f6f7a3dfaeabfaa3e849e915a4e44c209ee1860d6b4eaf745176ca59cb37031ebc13b170fa4f48e22c8c4b20d7a2d007f5d193
+DIST Test-DistManifest-1.014.tar.gz 35599 SHA256 3d26c20df42628981cbfcfa5b1ca028c6ceadb344c1dcf97a25ad6a88b73d7c5 SHA512 571d4771c0ca51578df38adbc000e8063e44e56d89217d1dacf3347b6f2f5c18597a67d999b00f51926725198991891d87cab6b6df31ddfca91b051bee7f7140 WHIRLPOOL 937cadf145f6e6b8d7dd6d56c93cfafab5edc9e5509c00a43ec02c324ef5b3f7ee4ae584066bb638a842fc85b2a82b07a6dc0458ef9af1b3c47e131682f88c8f
diff --git a/dev-perl/Test-DistManifest/Test-DistManifest-1.12.0-r1.ebuild b/dev-perl/Test-DistManifest/Test-DistManifest-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..7827dd1c2996
--- /dev/null
+++ b/dev-perl/Test-DistManifest/Test-DistManifest-1.12.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=1.012
+inherit perl-module
+
+DESCRIPTION="Author test that validates a package MANIFEST"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Module-Manifest
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-NoWarnings
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Test-DistManifest/Test-DistManifest-1.14.0.ebuild b/dev-perl/Test-DistManifest/Test-DistManifest-1.14.0.ebuild
new file mode 100644
index 000000000000..9dc89304e0f3
--- /dev/null
+++ b/dev-perl/Test-DistManifest/Test-DistManifest-1.14.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=1.014
+inherit perl-module
+
+DESCRIPTION="Author test that validates a package MANIFEST"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-ExtUtils-Manifest
+ virtual/perl-File-Spec
+ >=dev-perl/Module-Manifest-0.70.0
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.39.0
+ test? (
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-if
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Test-DistManifest/metadata.xml b/dev-perl/Test-DistManifest/metadata.xml
new file mode 100644
index 000000000000..27325aa22ef7
--- /dev/null
+++ b/dev-perl/Test-DistManifest/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Test-DistManifest</remote-id>
+ <remote-id type="cpan-module">Test::DistManifest</remote-id>
+ </upstream>
+</pkgmetadata>