summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-01 00:28:48 +1300
committerKent Fredric <kentnl@gentoo.org>2017-04-01 00:29:06 +1300
commit37ac41a82625b51fc96839e02c3052d8d61a7f86 (patch)
tree169d78f5f955c6c2a61a3e533bfd5b2787aee320 /dev-perl/Test-Deep
parentmail-client/claws-mail: add ~ppc64 keyword (bug 614064). (diff)
downloadgentoo-37ac41a82625b51fc96839e02c3052d8d61a7f86.tar.gz
gentoo-37ac41a82625b51fc96839e02c3052d8d61a7f86.tar.bz2
gentoo-37ac41a82625b51fc96839e02c3052d8d61a7f86.zip
dev-perl/Test-Deep: Bump to version 1.126.0
Upstream: - documentation improvements - more careful guard of $@ - Add control var ::LeafWrapper - Advoid relying on '.' in @INC in tests - Include stringified result of failed overloaded re match in diag - Don't warn when array_each() compares to nonref - objects on "expected" side with a 'as_test_deep_cmp' method can compare against that methods return instead of the object - class_base routine removed Bug: https://bugs.gentoo.org/614340 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Test-Deep')
-rw-r--r--dev-perl/Test-Deep/Manifest1
-rw-r--r--dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Test-Deep/Manifest b/dev-perl/Test-Deep/Manifest
index 9e58452b48c6..630e209f3d18 100644
--- a/dev-perl/Test-Deep/Manifest
+++ b/dev-perl/Test-Deep/Manifest
@@ -1 +1,2 @@
DIST Test-Deep-1.120.tar.gz 38973 SHA256 207ef8ea71291e5cf8258d1a4d98d360b9b5870989d187b3e2ff3c0fb201becd SHA512 8511a3070db440b8bde3c58c2c3f9cfe81900c96e27c474d7f21c1bdcc7846b7d7bb11a3c32dabe1183957c98f0bece0442cf9874514fbe3893c88919fd35b54 WHIRLPOOL 3fd67eae99e04c42bbc5c6abea3911a56c4e816f5041d5fd87acd3032b0e8253bf927a175ef13d65de28a5515afecb2817224451a55f9bc6be1da204337bb04e
+DIST Test-Deep-1.126.tar.gz 41285 SHA256 159b42451e4018d9da97994f4ac46d5166abf9b6f343db30071c8fd1cfe0c7c2 SHA512 e4667a3294a6a9d4b2a35e1c6dcc2b52db92589f3060e69fc7d4a4cad604dd2484341156b2cfeabdb4f70b777b687297be93b84a33838eb9622b734569ae9b33 WHIRLPOOL 7d9222e59d5e11dc3e0c9574c712176da407787050308a24491b808c3b90463c2696ce5251518612bfc7c40161129b130ae58e3c35fee0ad6dc0c1ded4bc0da7
diff --git a/dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild b/dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild
new file mode 100644
index 000000000000..fe2ec999e4b5
--- /dev/null
+++ b/dev-perl/Test-Deep/Test-Deep-1.126.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=1.126
+inherit perl-module
+
+DESCRIPTION="Extremely flexible deep comparison testing"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Scalar-List-Utils-1.90.0
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+src_test() {
+ # Bug 584238 Avoidance
+ if perl -e 'exit ( eval { require Test::Tester; Test::Tester->VERSION(0.04); 1 } ? 0 : 1 )'; then
+ perl-module_src_test
+ else
+ einfo "Test phase skipped: Test::Tester required for tests"
+ einfo "Please upgrade to >=dev-lang/perl-5.22.0 or >=virtual/perl-Test-Simple-1.1.10"
+ einfo "if you want this tested"
+ fi
+}