summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-06 10:36:51 +0100
committerSam James <sam@gentoo.org>2024-05-06 10:36:51 +0100
commitcffcdd3c1f03156c79802e55b35e73ce066729f7 (patch)
treea7cdaa4fd96d19d390fd7f8da88a02d701b21a58 /dev-perl/Test-Compile
parentsys-apps/util-linux: add 2.40.1 (diff)
downloadgentoo-cffcdd3c1f03156c79802e55b35e73ce066729f7.tar.gz
gentoo-cffcdd3c1f03156c79802e55b35e73ce066729f7.tar.bz2
gentoo-cffcdd3c1f03156c79802e55b35e73ce066729f7.zip
dev-perl/Test-Compile: add 3.3.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Compile')
-rw-r--r--dev-perl/Test-Compile/Manifest1
-rw-r--r--dev-perl/Test-Compile/Test-Compile-3.3.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Manifest b/dev-perl/Test-Compile/Manifest
index 17fd8b9f4e87..2b30d7671892 100644
--- a/dev-perl/Test-Compile/Manifest
+++ b/dev-perl/Test-Compile/Manifest
@@ -1,2 +1,3 @@
DIST Test-Compile-v3.3.1.tar.gz 20205 BLAKE2B 5a1b52447eb8e1f92903e3eae09f3b91fef4ba9bb7962edc854629a730dc8c0e622aaf78a13e6ec26a002749cfd9d112f4d2aa33acfb6a2775ce5b77a026ff04 SHA512 d2655da234eabd79846a97f358552d8f57cfdbd5de900850dd4537985a226a17e6277a45d0e118ab29df0084ae0edef14001c53be3f07e47e14c6cd2aa53ece3
DIST Test-Compile-v3.3.2.tar.gz 20668 BLAKE2B 7a0159e151ac0344b9d736d0abc02eae9e191ad4e2fd4c84cc3cf27c869ecd1546c2e4e28be8092c12b877c2139425526de1cdf44d167a84972b5e5f625e5227 SHA512 5403dd9b22f8b40fd8a64417d44219cacfe50d3200a0093171fd36460e7da9db97e6db85c618ace55218fb0ef64f3cef087bfba16f68e186344909957fbd8813
+DIST Test-Compile-v3.3.3.tar.gz 20685 BLAKE2B e09707215ace0c55a74eaa4321aa56461431960848c5bf54162d4b0c5f57ab60a7d988754f440782d3b7d507d084539a2087250ca4c6e80bbbce51d199f046b1 SHA512 ba437e9864fe849276d7ff4b4b89ab25800286777f9001cf7c66b0996025d1edd93faa7f74292a07786cac9446a8e1cde2ccc37d6f7339c8605b9342fec03b1d
diff --git a/dev-perl/Test-Compile/Test-Compile-3.3.3.ebuild b/dev-perl/Test-Compile/Test-Compile-3.3.3.ebuild
new file mode 100644
index 000000000000..7b1c7a6fdf04
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-3.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Exporter-5.680.0
+ >=virtual/perl-parent-0.225.0
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)