summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-18 22:50:56 +0100
committerSam James <sam@gentoo.org>2023-07-18 22:52:11 +0100
commit2e8e295adf98bd7f8fd70aee0195435ee921c472 (patch)
tree4c3d4f9ed95f169045401e49dce2501723db4f0d /dev-perl/Test-Compile
parentdev-perl/Business-ISBN-Data: add 20230718.1.0 (diff)
downloadgentoo-2e8e295adf98bd7f8fd70aee0195435ee921c472.tar.gz
gentoo-2e8e295adf98bd7f8fd70aee0195435ee921c472.tar.bz2
gentoo-2e8e295adf98bd7f8fd70aee0195435ee921c472.zip
dev-perl/Test-Compile: add 3.3.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Compile')
-rw-r--r--dev-perl/Test-Compile/Manifest1
-rw-r--r--dev-perl/Test-Compile/Test-Compile-3.3.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Manifest b/dev-perl/Test-Compile/Manifest
index fba86c90a405..ca6743d60236 100644
--- a/dev-perl/Test-Compile/Manifest
+++ b/dev-perl/Test-Compile/Manifest
@@ -2,3 +2,4 @@ DIST Test-Compile-v2.4.2.tar.gz 18842 BLAKE2B 6bc8dbd692087ccbf41b227c417f1cb8a1
DIST Test-Compile-v3.0.1.tar.gz 18490 BLAKE2B d472567065549a6a00c668aa5d7af1597f5d3fe0f06a849b374fe0b6757ef5a591ddb5834c894c64c48d9eabe5112803509dba9b4698afed6e028a5010ae4b5f SHA512 a8e5d0fabaaa0c8d4de716da85279c8d4abdcfb8e453159f5b47d10e1845d2f80164d099bcd3906d74afae1137fd9d4430d47b8bdcb3afc6d81b8043bd585715
DIST Test-Compile-v3.2.2.tar.gz 19612 BLAKE2B e6a14624c1aaf70e5228d46ed33313e07ecfd2632ef8e369c2046317dac5ff83f48efe853f06436d71b98721cb8f5b5e6354a4d62c67351297b512a1be1152a7 SHA512 68a18cee66cc8eb2bf10b3d7f97244ee49d7162284957a8f34226846f3afda1872c809b4cdd7494286afea255313eeba27f392e3827ed127d39bbdf406be8151
DIST Test-Compile-v3.3.0.tar.gz 20143 BLAKE2B 701b72181807a44bb46944e0e505644521b10b16a4180e6f4e1ce3a2e41a185a4471e9bc9b1d1e8aefd6485d5db898fa408dd7f09fff22ff7d33f980898a2123 SHA512 41c05d70e2913905d886651e1f882bd145c0f4c9ed433e8541cb9cf33e622f7c34ebe5c9eb875161782cf8a7bafc6bdc2f03b60c8bbef7f9ff0381d833f5205a
+DIST Test-Compile-v3.3.1.tar.gz 20205 BLAKE2B 5a1b52447eb8e1f92903e3eae09f3b91fef4ba9bb7962edc854629a730dc8c0e622aaf78a13e6ec26a002749cfd9d112f4d2aa33acfb6a2775ce5b77a026ff04 SHA512 d2655da234eabd79846a97f358552d8f57cfdbd5de900850dd4537985a226a17e6277a45d0e118ab29df0084ae0edef14001c53be3f07e47e14c6cd2aa53ece3
diff --git a/dev-perl/Test-Compile/Test-Compile-3.3.1.ebuild b/dev-perl/Test-Compile/Test-Compile-3.3.1.ebuild
new file mode 100644
index 000000000000..7577d8d71c55
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-3.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Exporter-5.680.0
+ >=virtual/perl-parent-0.225.0
+ >=virtual/perl-version-0.770.0
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)