summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-13 22:49:27 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-13 22:50:20 +1300
commitb8215cc4b25a990669d40cb047e36c081ee658fc (patch)
tree0f2cfe01a005b42e6c2628388854f238beff37aa /dev-perl/Net-ARP/Net-ARP-1.0.9-r1.ebuild
parentdev-libs/libxslt: remove redundant revisions, security cleanup (diff)
downloadgentoo-b8215cc4b25a990669d40cb047e36c081ee658fc.tar.gz
gentoo-b8215cc4b25a990669d40cb047e36c081ee658fc.tar.bz2
gentoo-b8215cc4b25a990669d40cb047e36c081ee658fc.zip
dev-perl/Net-ARP: EAPI6 + Tests
- EAPI6ify - Enable tests - Fix tests failing due to '.' in @INC - Fix tests failing due to assumptions about root/network devices - Document extended testing strategy Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Net-ARP/Net-ARP-1.0.9-r1.ebuild')
-rw-r--r--dev-perl/Net-ARP/Net-ARP-1.0.9-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Net-ARP/Net-ARP-1.0.9-r1.ebuild b/dev-perl/Net-ARP/Net-ARP-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..30628f62959b
--- /dev/null
+++ b/dev-perl/Net-ARP/Net-ARP-1.0.9-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CRAZYDJ
+DIST_VERSION=1.0.9
+DIST_A_EXT=tgz
+inherit perl-module
+
+DESCRIPTION="Perl extension for creating ARP packets"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-perl/Net-Pcap"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/1.0.9-header.diff"
+ "${FILESDIR}/${PN}-1.0.9-perl-5.26.patch"
+ "${FILESDIR}/${PN}-1.0.9-tests.patch"
+)
+
+src_prepare() {
+ perl -MDevel::PPPort -e 'Devel::PPPort::WriteFile();'
+ perl-module_src_prepare
+}
+
+src_test() {
+ if [[ $EUID != 0 || -z $TEST_ARP_IF ]]; then
+ elog "Comprehensive testing needs additional configuration (and root)."
+ elog "For details, see:"
+ elog "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+ fi
+ perl-module_src_test
+}