summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 12:44:18 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 12:44:18 +1200
commitcc885d37855f057d1bd8defe1d2916e1f824ca24 (patch)
tree6b50582f442e14eb3a758a19fea026822b7698ef /dev-perl/Mojolicious
parentdev-perl/Mojolicious: Bump to version 8.200.0 (diff)
downloadgentoo-cc885d37855f057d1bd8defe1d2916e1f824ca24.tar.gz
gentoo-cc885d37855f057d1bd8defe1d2916e1f824ca24.tar.bz2
gentoo-cc885d37855f057d1bd8defe1d2916e1f824ca24.zip
dev-perl/Mojolicious: Bump to version 8.300.0
Upstream: - *un*deprecate Mojo::Exception::verbose - add ENV var MOJO_EXCEPTION_VERBOSE - Built in templates now use the same stacktrace format as Mojo::Exception - Fix Mojo::Exception not correctly stringifying messages ending with "\n" - Mojo::Exception now appends file and line number to stringified exceptions that do not end with a "\n" - Update Cpanel::JSON::XS requirement to 4.09 for duplicate keys support - Add Mojo::Collection->{head,tail} - Mojo::File no longer allows undefined values in paths - Add experimental Mojo::Log->context - Add experimental Mojo::IOLoop::Subprocess `cleanup` event - Add `log` helper to Plugin::DefaultHelpers - Log messages generated by Mojolicious now include request_id's where possible - Add Mojo::File::curfile - Remove deprecated Mojo::Collection->slice - Move HTML entities from Mojo::Util to a seperate file - Event loop state determination in Reactor::EV now more consistent with Reactor::Poll - Add experimental `before_command` hook - Add experimental Mojo::Util::scope_guard - Mojo::Log->context no longer experimental - Default Mojolicious::Types content_type MIME type is now `application/octet-stream` - Add experimental async/await support with `Mojo::Base -async` - Add experimental Mojo::Promise->{all_settled,any} Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Mojolicious')
-rw-r--r--dev-perl/Mojolicious/Manifest1
-rw-r--r--dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Manifest b/dev-perl/Mojolicious/Manifest
index cc58b87124c1..44decfd79a9d 100644
--- a/dev-perl/Mojolicious/Manifest
+++ b/dev-perl/Mojolicious/Manifest
@@ -7,3 +7,4 @@ DIST Mojolicious-7.94.tar.gz 747870 BLAKE2B 9a36cdaf8c76a17c424aa08f160189dba0e5
DIST Mojolicious-8.0.tar.gz 748351 BLAKE2B d1fb38dbe26561247050d07b6108fe423921d119f5823915d921df2d390acd39561c9afcfe7c58bb49c419b167de710ce08409a2cba5225ea36aa12cce7a2fe7 SHA512 19126a663c52a45f1f32354567b97922453b542073308d2b7288f9deb568f598a2e7ed5b6db377bcb152437c942ed47f8fd805fae80d3f54db02d3a7160cc94e
DIST Mojolicious-8.10.tar.gz 754007 BLAKE2B 2ac7887e431598e7347999180a5d9e46c76a42cb9e2452645ece188055a2a27608c6398a18045356e1d87489e63d95358fa4e16e8d3d3bb310cd40867bd25586 SHA512 e2cee767f6aba83668fd2c0c13a5aa7e11bbd07d42f7e7633cef3657705265066b787c62c23da9faf66f1110196412bec9e06584fc7790e14f73dbe46dc67c0f
DIST Mojolicious-8.20.tar.gz 764063 BLAKE2B 846bb3cfeac502d808f28f26921a73e09587df9a792ffb737cce9f8d2cdd5224f563a79aebdae67f8df50fee8bade687e875cf056510d26960b7852aad128326 SHA512 d5d178b428fc9df815106811c197f886845591819228aad2ef14cb6fad8c82e04479d434b4e4c7d2da042d868d624de7f2a0381ff0d1f82b7b60638feb4174d3
+DIST Mojolicious-8.30.tar.gz 772067 BLAKE2B b7f21b780a113aea3978968979e67442664104b15c6711d7f68d2dcb068fbb005135acf1845b0aeb4d43c2158672aab853aa862ba2ed1889242266c9ce80733f SHA512 1823a095df339ccdfe74395bb3066627bd5e2a4e9e1b8d907ff716ef511bd834e09c0aa703a1e51f675d2125f2848a25fa4efb2f48f9c5dcbe1dc8a1d0c48ff5
diff --git a/dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild b/dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild
new file mode 100644
index 000000000000..d2daab52837d
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-8.300.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SRI
+DIST_VERSION=8.30
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-JSON-PP-2.271.30
+ >=virtual/perl-Scalar-List-Utils-1.410.0
+ >=virtual/perl-Time-Local-1.200.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod_coverage.t
+)