summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-02-04 13:22:50 +1300
committerKent Fredric <kentnl@gentoo.org>2020-02-05 14:01:38 +1300
commit23c224b54e7b70537aaaf7a7e59c6ec677459c0e (patch)
tree31072f044c250e6ac64137e4e797f9fcca19fc2d /dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild
parentdev-perl/Data-IEEE754: Add w/ version=0.20.0 (diff)
downloadgentoo-23c224b54e7b70537aaaf7a7e59c6ec677459c0e.tar.gz
gentoo-23c224b54e7b70537aaaf7a7e59c6ec677459c0e.tar.bz2
gentoo-23c224b54e7b70537aaaf7a7e59c6ec677459c0e.zip
dev-perl/Math-Int64: Add w/ version=0.540.0
Required for dev-perl/GeoIP2, as suggested by Tomáš Mózes Bug: https://github.com/gentoo/gentoo/pull/13973 Bug: https://bugs.gentoo.org/67549 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild')
-rw-r--r--dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild b/dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild
new file mode 100644
index 000000000000..f823edafd09e
--- /dev/null
+++ b/dev-perl/Math-Int64/Math-Int64-0.540.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.54
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Manipulate 64 bits integers in Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Storable
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-eol.t" "t/author-no-tabs.t" "t/author-pod-spell.t"
+ "t/author-pod-syntax.t" "t/release-cpan-changes.t" "t/release-pod-coverage.t"
+ "t/release-portability.t" "t/release-synopsis.t"
+)