summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-02 04:18:33 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-02 07:25:57 +1300
commit7d6cbab894c0d580da0dac9354d1d9d60817a0c0 (patch)
tree7deabeded14b815f90a97d4bb4115a296d3848b5 /dev-perl/Math-GMP/Math-GMP-2.150.0.ebuild
parentdev-perl/Math-Derivative: Bump to version 1.10.0 (diff)
downloadgentoo-7d6cbab894c0d580da0dac9354d1d9d60817a0c0.tar.gz
gentoo-7d6cbab894c0d580da0dac9354d1d9d60817a0c0.tar.bz2
gentoo-7d6cbab894c0d580da0dac9354d1d9d60817a0c0.zip
dev-perl/Math-GMP: Bump to version 2.150.0
- Add broot, brootrem, bsqrtrem, is_perfect_power, is_perfect_square - Fix tests on older libgmps Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Math-GMP/Math-GMP-2.150.0.ebuild')
-rw-r--r--dev-perl/Math-GMP/Math-GMP-2.150.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Math-GMP/Math-GMP-2.150.0.ebuild b/dev-perl/Math-GMP/Math-GMP-2.150.0.ebuild
new file mode 100644
index 000000000000..837f47dfdc93
--- /dev/null
+++ b/dev-perl/Math-GMP/Math-GMP-2.150.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.15
+inherit perl-module
+
+DESCRIPTION="High speed arbitrary size integer math"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-AutoLoader
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ dev-libs/gmp:0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Devel-CheckLib-0.900.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"