summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-06 12:02:57 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-06 12:02:57 +1200
commite5a73f45ea4787ab6463a5cd76f70bdf97f5c686 (patch)
treeaffa40497062624d10ce1ea1753c0f4c7344f527 /dev-perl/MCE/MCE-1.827.0.ebuild
parentdev-perl/Text-CSV: Bump to version 1.930.0 (diff)
downloadgentoo-e5a73f45ea4787ab6463a5cd76f70bdf97f5c686.tar.gz
gentoo-e5a73f45ea4787ab6463a5cd76f70bdf97f5c686.tar.bz2
gentoo-e5a73f45ea4787ab6463a5cd76f70bdf97f5c686.zip
dev-perl/MCE: Bump to version 1.827.0
Upstream: - Dont enable barrier mode in Queue when constructed inside thread or by MCE Model - Don't croak under taint Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/MCE/MCE-1.827.0.ebuild')
-rw-r--r--dev-perl/MCE/MCE-1.827.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/MCE/MCE-1.827.0.ebuild b/dev-perl/MCE/MCE-1.827.0.ebuild
new file mode 100644
index 000000000000..39184ec6d738
--- /dev/null
+++ b/dev-perl/MCE/MCE-1.827.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARIOROY
+DIST_VERSION=1.827
+inherit perl-module
+
+DESCRIPTION="Many-Core Engine providing parallel processing capabilities"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test +sereal"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Socket
+ >=virtual/perl-Storable-2.40.0
+ virtual/perl-Time-HiRes
+ sereal? (
+ >=dev-perl/Sereal-Encoder-3.15.0
+ >=dev-perl/Sereal-Decoder-3.15.0
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"