summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Inline
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Inline')
-rw-r--r--dev-perl/Inline/Inline-0.500.0-r1.ebuild29
-rw-r--r--dev-perl/Inline/Inline-0.790.0.ebuild33
-rw-r--r--dev-perl/Inline/Inline-0.800.0.ebuild29
-rw-r--r--dev-perl/Inline/Manifest3
-rw-r--r--dev-perl/Inline/files/gtk2-patch.diff32
-rw-r--r--dev-perl/Inline/metadata.xml17
6 files changed, 143 insertions, 0 deletions
diff --git a/dev-perl/Inline/Inline-0.500.0-r1.ebuild b/dev-perl/Inline/Inline-0.500.0-r1.ebuild
new file mode 100644
index 000000000000..054056d7aaec
--- /dev/null
+++ b/dev-perl/Inline/Inline-0.500.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SISYPHUS
+MODULE_VERSION=0.50
+inherit perl-module
+
+DESCRIPTION="Write Perl subroutines in other languages"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="test"
+
+RDEPEND="virtual/perl-Digest-MD5
+ virtual/perl-File-Spec
+ dev-perl/Parse-RecDescent"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Warn
+ )"
+
+SRC_TEST=do
+
+src_test() {
+ MAKEOPTS+=" -j1" perl-module_src_test # bug 384137
+}
diff --git a/dev-perl/Inline/Inline-0.790.0.ebuild b/dev-perl/Inline/Inline-0.790.0.ebuild
new file mode 100644
index 000000000000..afb1fe74d2c2
--- /dev/null
+++ b/dev-perl/Inline/Inline-0.790.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=INGY
+MODULE_VERSION=0.79
+inherit perl-module
+
+DESCRIPTION="Write Perl subroutines in other languages"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Spec
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-Warn-0.230.0
+ )
+"
+
+SRC_TEST=do
+
+src_test() {
+ MAKEOPTS+=" -j1" perl-module_src_test # bug 384137
+}
diff --git a/dev-perl/Inline/Inline-0.800.0.ebuild b/dev-perl/Inline/Inline-0.800.0.ebuild
new file mode 100644
index 000000000000..3e6cb3dfcbab
--- /dev/null
+++ b/dev-perl/Inline/Inline-0.800.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=INGY
+MODULE_VERSION=0.80
+inherit perl-module
+
+DESCRIPTION="Write Perl subroutines in other languages"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Spec
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-Warn-0.230.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Inline/Manifest b/dev-perl/Inline/Manifest
new file mode 100644
index 000000000000..192b48ae64a5
--- /dev/null
+++ b/dev-perl/Inline/Manifest
@@ -0,0 +1,3 @@
+DIST Inline-0.50.tar.gz 104632 SHA256 6263fa1145efe9e96bcd60d10f9eabd93313e00cb1e555abddda1e98b7c280d6 SHA512 58b2968d3602c0703cc191216ca3dd0ef877b833d5bf8848e4ad76fbbf06d5ab5e5953253334614d397fe961ba72446b639cac186709234fd26a99be37ba0c3c WHIRLPOOL b3c5e0ff14779111c727d6df868720527acd4727f71327be4478397edf947755c158c71b28e0ed6b0fc219e6f5bf5b5f2b4ce844c938c1bcd32571d72332f582
+DIST Inline-0.79.tar.gz 78224 SHA256 525214a46d9dd0267bb5815dfbbd78a2544157895676d38917fa5a9728cc7b94 SHA512 8a99fe9900a99950cd52d4a75c41bf7a522aa00468562baaa5d86a6e02724b6d4f8f3f08bf565b03693ffe16bbd5738e693dccf60b0451f044b6c468b95e37dc WHIRLPOOL b451f7b17ebef63e210cd0afcc7fb48d2b4f23747ecdc83ba23689e633bdcb3e9025ebcabc67bcf6714c5e87363d82b36f976b0c3e6bdcd9dbf29298633c3358
+DIST Inline-0.80.tar.gz 78254 SHA256 7e2bd984b1ebd43e336b937896463f2c6cb682c956cbd2c311a464363d2ccef6 SHA512 e64f7752f32fd07c7c7a975429e04730f2987c9588f99b95502d4e5c87d458736a606c03943a68660940c3987cd632ad2f75ec3862342956c1754b1aca86e0bb WHIRLPOOL 1b16d389e793a99e5cb0d733852f97ab33ee177cc857fb56b0f5b76a113f8b12c982e816de35e7b6978baa752c81b26f15cac2874ab5ec3cdae2d0076b9f2880
diff --git a/dev-perl/Inline/files/gtk2-patch.diff b/dev-perl/Inline/files/gtk2-patch.diff
new file mode 100644
index 000000000000..bf28ec596f7b
--- /dev/null
+++ b/dev-perl/Inline/files/gtk2-patch.diff
@@ -0,0 +1,32 @@
+*** Inline-0.44/lib/Inline/denter.pm-orig 2001-06-13 06:30:50.000000000 +0200
+--- Inline-0.44/lib/Inline/denter.pm 2002-11-13 15:43:41.000000000 +0100
+***************
+*** 177,182 ****
+--- 177,183 ----
+ }
+
+ sub _next_line {
++ local ($_);
+ my $o = shift;
+ $o->{done}++, $o->{level} = -1, return unless @{$o->{lines}};
+ $_ = shift @{$o->{lines}};
+***************
+*** 188,193 ****
+--- 189,195 ----
+ $o->{done}++, $o->{level} = -1, return unless @{$o->{lines}};
+ my ($width, $tabwidth) = @{$o}{qw(width tabwidth)};
+ while (1) {
++ local ($_);
+ $_ = $o->{lines}[0];
+ # expand tabs in leading whitespace;
+ $o->next_line, next if /^(\s*$|\#)/; # skip comments and blank lines
+***************
+*** 221,226 ****
+--- 223,229 ----
+
+ sub indent_data {
+ my $o = shift;
++ local ($_);
+ $_ = shift;
+ return $o->indent_undef($_)
+ if not defined;
diff --git a/dev-perl/Inline/metadata.xml b/dev-perl/Inline/metadata.xml
new file mode 100644
index 000000000000..488b00aecebf
--- /dev/null
+++ b/dev-perl/Inline/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Inline</remote-id>
+ <remote-id type="cpan-module">Foo::Tester</remote-id>
+ <remote-id type="cpan-module">Inline</remote-id>
+ <remote-id type="cpan-module">Inline::C</remote-id>
+ <remote-id type="cpan-module">Inline::C::ParseRecDescent</remote-id>
+ <remote-id type="cpan-module">Inline::C::ParseRegExp</remote-id>
+ <remote-id type="cpan-module">Inline::Foo</remote-id>
+ <remote-id type="cpan-module">Inline::MakeMaker</remote-id>
+ <remote-id type="cpan-module">Inline::denter</remote-id>
+ <remote-id type="cpan-module">Math::Simple</remote-id>
+ </upstream>
+</pkgmetadata>