summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-21 21:35:04 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-21 21:53:03 +1200
commit1993d3d63137627f7e7ae4be98ddd2209c93663f (patch)
treeb482eb045e570fcfa60bd95b709db476aabcd3c0 /dev-perl/Inline-Python
parentgames-puzzle/colorcode: EAPI-7 bump, eutils -> desktop.eclass (diff)
downloadgentoo-1993d3d63137627f7e7ae4be98ddd2209c93663f.tar.gz
gentoo-1993d3d63137627f7e7ae4be98ddd2209c93663f.tar.bz2
gentoo-1993d3d63137627f7e7ae4be98ddd2209c93663f.zip
dev-perl/Inline-Python: Add support up to python3_8
- EAPI7 conversion - Add python3_7 and python3_8 support Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Inline-Python')
-rw-r--r--dev-perl/Inline-Python/Inline-Python-0.560.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Inline-Python/Inline-Python-0.560.0-r1.ebuild b/dev-perl/Inline-Python/Inline-Python-0.560.0-r1.ebuild
new file mode 100644
index 000000000000..08eec2057680
--- /dev/null
+++ b/dev-perl/Inline-Python/Inline-Python-0.560.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+# Feel free to add more targets after testing.
+
+DIST_AUTHOR=NINE
+DIST_VERSION=0.56
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ >=virtual/perl-Digest-MD5-2.500.0
+ >=dev-perl/Inline-0.460.0
+ ${PYTHON_DEPS}
+"
+DEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Proc-ProcessTable-0.530.0
+ virtual/perl-Test-Simple
+ dev-perl/Test-Deep
+ dev-perl/Test-Number-Delta
+ virtual/perl-Test
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.460.0-insanepython.patch" )