summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-06-08 16:38:23 +1200
committerKent Fredric <kentnl@gentoo.org>2018-06-08 16:38:49 +1200
commit296b8a0587807043c054d6e421384516d27cbed5 (patch)
tree5b28bdc96e61c5e70484462d150d6f0f86b45896 /dev-perl/ExtUtils-F77
parentmedia-libs/mesa: Simplify driver selection code (diff)
downloadgentoo-296b8a0587807043c054d6e421384516d27cbed5.tar.gz
gentoo-296b8a0587807043c054d6e421384516d27cbed5.tar.bz2
gentoo-296b8a0587807043c054d6e421384516d27cbed5.zip
dev-perl/ExtUtils-F77: Require a fortran implementation bug #656226
This module autoswitches between a bunch of fortran implementations, however, it helps to actually have one installed first. Failures occur as a result of attempting to use a default (which is not installed) when discovery fails Closes: https://bugs.gentoo.org/656226 Package-Manager: Portage-2.3.29, Repoman-2.3.9
Diffstat (limited to 'dev-perl/ExtUtils-F77')
-rw-r--r--dev-perl/ExtUtils-F77/ExtUtils-F77-1.200.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-perl/ExtUtils-F77/ExtUtils-F77-1.200.0-r1.ebuild b/dev-perl/ExtUtils-F77/ExtUtils-F77-1.200.0-r1.ebuild
new file mode 100644
index 000000000000..d50e1a9dbcbb
--- /dev/null
+++ b/dev-perl/ExtUtils-F77/ExtUtils-F77-1.200.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CHM
+DIST_VERSION=1.20
+inherit perl-module
+
+DESCRIPTION="Facilitate use of FORTRAN from Perl/XS code"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="virtual/perl-File-Spec
+ virtual/fortran
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"