summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-03 01:58:13 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-03 01:58:41 +1200
commit5b8c8e28327dfc8642a5248a2ab0b48dc56319a9 (patch)
treee8312d07453e3d02a682d4b073a319e6aac510e1 /dev-perl/Crypt-Simple
parentmedia-libs/glm: Version bump to 0.9.9.8 (diff)
downloadgentoo-5b8c8e28327dfc8642a5248a2ab0b48dc56319a9.tar.gz
gentoo-5b8c8e28327dfc8642a5248a2ab0b48dc56319a9.tar.bz2
gentoo-5b8c8e28327dfc8642a5248a2ab0b48dc56319a9.zip
dev-perl/Crypt-Simple: -r bump for EAPI7 + fixes
- EAPI7 - Remove redundancy in DESCRIPTION - Fix incorrect LICENSE - Qualify dependencies - Ensure no parallel tests under EAPI7 due to file races Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-Simple')
-rw-r--r--dev-perl/Crypt-Simple/Crypt-Simple-0.60.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Simple/Crypt-Simple-0.60.0-r2.ebuild b/dev-perl/Crypt-Simple/Crypt-Simple-0.60.0-r2.ebuild
new file mode 100644
index 000000000000..9ffc027b0071
--- /dev/null
+++ b/dev-perl/Crypt-Simple/Crypt-Simple-0.60.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KASEI
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="encrypt stuff simply"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Crypt-Blowfish-2.60.0
+ >=virtual/perl-Digest-MD5-2.130.0
+ >=dev-perl/FreezeThaw-0.410.0
+ >=virtual/perl-IO-Compress-1.110.0
+ >=virtual/perl-MIME-Base64-2.110.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Harness )
+"
+DIST_TEST="do" # concurrent io in tests