summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-22 18:29:47 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-22 18:31:11 +1200
commitd2ff91f81ebd213077188aeb1c31ba818a8c2141 (patch)
treea9868b2c4941d4ceaf87bcc3fd771ed650420075 /dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r2.ebuild
parentdev-perl/Class-Autouse: Fix broken Module::Install::DSL patching (diff)
downloadgentoo-d2ff91f81ebd213077188aeb1c31ba818a8c2141.tar.gz
gentoo-d2ff91f81ebd213077188aeb1c31ba818a8c2141.tar.bz2
gentoo-d2ff91f81ebd213077188aeb1c31ba818a8c2141.zip
dev-perl/Chart-Math-Axis: Fix broken Module::Install::DSL patching
For some rediculous reason, this module changes everything about Perl, so optional newlines cease to be optional. Additionally, this causes configure to exit true, but fail to configure. And this breaks install time, necessitating an -r1 bump. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r2.ebuild')
-rw-r--r--dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r2.ebuild b/dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r2.ebuild
new file mode 100644
index 000000000000..318e59d6ff4e
--- /dev/null
+++ b/dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=1.06
+inherit perl-module
+
+DESCRIPTION="Implements an algorithm to find good values for chart axis"
+
+SLOT="0"
+KEYWORDS="amd64 hppa ~mips ~ppc x86"
+IUSE=""
+
+RDEPEND=">=virtual/perl-Math-BigInt-1.70
+ >=virtual/perl-Storable-2.12
+ >=dev-perl/Params-Util-0.15"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install::DSL /use lib q[.];\nuse inc::Module::Install::DSL /' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}