summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-02-01 10:37:26 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-02-01 10:37:26 +0100
commite8cdb016804e65caca991b7ae3cf5c4c65af01b1 (patch)
tree975fd09a6e92d9b53bd1ae2f48c2cbd759cd4fdb /dev-ml
parentdev-java/commons-jxpath: removed obsolete 1.3-r3 (diff)
downloadgentoo-e8cdb016804e65caca991b7ae3cf5c4c65af01b1.tar.gz
gentoo-e8cdb016804e65caca991b7ae3cf5c4c65af01b1.tar.bz2
gentoo-e8cdb016804e65caca991b7ae3cf5c4c65af01b1.zip
dev-ml/opam-installer: 2.1.2 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-installer/Manifest1
-rw-r--r--dev-ml/opam-installer/opam-installer-2.1.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index 8f2c10b6c1c6..fcd39250269c 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -4,3 +4,4 @@ DIST opam-full-2.0.8.tar.gz 8006252 BLAKE2B 26348bdbb8bdc2fbf9d736286c1f4134ce06
DIST opam-full-2.0.9.tar.gz 8029605 BLAKE2B c2ae06bdbbdbe9db270ec0027ec8d13a228f0af2ae5089476fa3a698d27e1f47abf2e3a15ecc9ca610717ba6b979b4ca76cce56c52f6592ae789b88fb5e5b68d SHA512 9f44d878a2599a876f5e5b9b7457b6f446a5e59156ed3d449dcc29e40c44df8b69da619eabdf030e45526fba4bd9a00c65dec2c36552d2e03788596b0aceee85
DIST opam-full-2.1.0.tar.gz 9136886 BLAKE2B 3d51159568b6e85834f70a3545fe37d82470d4253bf9db6fef32b4314fd0a82182737bba6be62a9dd04b6d8fb8d7468b2e23ac39fa475f467adfdb0ec8d52181 SHA512 2c4955e450cde7211dbab507cbdc5d6e67805353e384df525d77ebf5561d6a4de91f7e5691567b2dc61146fc29df6fa5dc8aa8562330a4746db3a52b7487811a
DIST opam-full-2.1.1.tar.gz 9275192 BLAKE2B b5729bc938633073efdf979f8e160c42aee682fe311b613d4d82be7add64b42506d1b6c107f3770fd8de4dc9eed7076f7774a34482d1956b8bd6315f551aea6d SHA512 7876a015fc2a421f70f9e8fa35c7ce56397dde7b679f3aba73c2a38f4967afc410c707a00f0a107baf353efe8bb6d4eee0601a5e205dc05a0f9c3d2a0c4d44d8
+DIST opam-full-2.1.2.tar.gz 9442446 BLAKE2B fe5447fe8f9bcedb30bf455e93b54a37e950e2944f6f501545bdccf6d989de2da90106938efb6a12c1b9454ecefed5be9906d65a15a4d0244302ad7ccff170db SHA512 fe12aaa27168435a978c472926d40697af0a7619a529c4bfacd0b71469dfcd534f43164bc74f60f740a735d38a869ae5e87e2414119f4f3fc1826315e8a075cd
diff --git a/dev-ml/opam-installer/opam-installer-2.1.2.ebuild b/dev-ml/opam-installer/opam-installer-2.1.2.ebuild
new file mode 100644
index 000000000000..d506458c738b
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit dune
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/_build/install/default/bin/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}
+ >=dev-ml/dose3-6
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}