summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-29 12:19:10 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-29 12:19:30 +0200
commitd367132793974b0f10f936869bea489d0fa7268c (patch)
tree623225f837d69e99eb15e6b67c9aeb86cfa568e3 /dev-ml
parentmedia-sound/gstreamripper: Fix C99 errors; update EAPI 7 -> 8 (diff)
downloadgentoo-d367132793974b0f10f936869bea489d0fa7268c.tar.gz
gentoo-d367132793974b0f10f936869bea489d0fa7268c.tar.bz2
gentoo-d367132793974b0f10f936869bea489d0fa7268c.zip
dev-ml/ocaml-ctypes: add 0.22.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 61634628689c..4031632b920e 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -2,3 +2,4 @@ DIST ocaml-ctypes-0.17.1.tar.gz 208101 BLAKE2B b9fe6632058a670c988ba9f1ae81b75aa
DIST ocaml-ctypes-0.20.0.tar.gz 206559 BLAKE2B d9bf1c3f5ae7544e3950766f7eb9bac2c9dbf84130f69b2b8807e55c6a7d659c46d9ba2227d53d578e4e49283730932213eea4c7487beffe4540432b3e700c81 SHA512 605ae95b0233f1157749475526ef00ade2f97649d06a782e8fcf97b604cb86a0dcc8f27c4ac6baec11a41b9ef5becb0e5ae55e30f1ee61b30d4ae17a0d1545c2
DIST ocaml-ctypes-0.20.1.tar.gz 206863 BLAKE2B a101872991d4bd83464d26e79fa5052c9dadbd10da1ae734fda8976199640091939777a1ba391d2aab84d7e14fafec6f713681e2ea52f6717f5f36d26e8aa225 SHA512 f95e65ce5003a07634afcbee431cb23c54c8335f926074615fc8d76ab777b9d2fce8f75bb25bbb6ed9550a7d6237fb377aa9ad65a426d2d7e387f86c1158fe4a
DIST ocaml-ctypes-0.21.1.tar.gz 200264 BLAKE2B c4539c8856c1919194f11ecaeb1b0649dc701a6c0dda62c4bb750cd64a9145f2e4a9e77392385e4e398e8e89d5ae91b7c5f68b6242f826563f0f32b78497dfe1 SHA512 3a64b29746360e7dda7725ce7af23ca64cd6a3fa585aa70188cdd143aace744f44c1bd13cdda5c9733ca53d4b874ed42749ca21aaff4f4d53636a390a2c7f94f
+DIST ocaml-ctypes-0.22.0.tar.gz 200377 BLAKE2B f9a27434a564d619d45bc4bd74fa0e045b21cf62e7b83203f25757e093e0ebff6b259b871eec57e404a3b043e4bbfc433a664d78e64b4b357730e09371a0d220 SHA512 98925bddfba81fd91383c5ee87a47f8f3424958e0affc299585b83029ce3cc52ac4c059f94d548cb15f37379ba3a8742a04b94f76787177b26c233b7037faa09
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild
new file mode 100644
index 000000000000..fbec82b5da87
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=ctypes
+inherit dune
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/yallop/ocaml-ctypes/"
+SRC_URI="https://github.com/yallop/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.03:=
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+ dev-ml/dune-configurator:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+REQUIRED_USE="ocamlopt"
+
+src_install() {
+ dune-install ctypes ctypes-foreign
+}