summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-01 20:23:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 11:33:27 +0200
commit3e8a8244abc1090dd2fef6b4813a807e37fc5df9 (patch)
treec0b5f2f9e3c43b670e7411470ea2441ced98f6a1 /dev-ml
parentapp-emulation/xen-tools: fix localstatedir path (diff)
downloadgentoo-3e8a8244abc1090dd2fef6b4813a807e37fc5df9.tar.gz
gentoo-3e8a8244abc1090dd2fef6b4813a807e37fc5df9.tar.bz2
gentoo-3e8a8244abc1090dd2fef6b4813a807e37fc5df9.zip
dev-ml/reason-parser: bump to 1.13.5
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/reason-parser/Manifest1
-rw-r--r--dev-ml/reason-parser/reason-parser-1.13.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/reason-parser/Manifest b/dev-ml/reason-parser/Manifest
index 4d9702169576..decfd0f8d936 100644
--- a/dev-ml/reason-parser/Manifest
+++ b/dev-ml/reason-parser/Manifest
@@ -1,2 +1,3 @@
DIST reason-parser-1.13.3.tar.gz 10253108 SHA256 b92840f8238dd6266c5678da3e4dc832776bcc98990ac47773020e34dce708a6 SHA512 82398fbbf72bcadfc868e5f33e8666ef80ef610f8313d08bc16593944569b7a16693fcc6397a117518bf8e32f71083f0ac4a416112f97cd220715f4293136b84 WHIRLPOOL a82dd8e28a012ed0716fba6bc79eee849110bfb42cd8221eb15847cadae90d62d909e635f3da465c6220382d6eee62f2f69a739d96d3d6a5baddc58623cd059e
DIST reason-parser-1.13.4.tar.gz 6856260 SHA256 07b0f4a471b570b9f6ee699016d2fb9d98788d1ccfb428a2b2f20f1ee6f42b9e SHA512 ee2270ffbb3c3c818aafec2ef0f23f3741e66e5b077b3a84b49b357b003d24d639165c521bf0afe92bf81ef626ed6d863ea6d097b83a2e1b5a0349a679cc8c7f WHIRLPOOL ffc8b96ce5b653c1d78877f0422315cce3d42615b88bb6f09f52d3af9799fe30ed221094a5acbc49448f0d1e865b1702a2b5956a8d327a22b2db01eb33aa0da7
+DIST reason-parser-1.13.5.tar.gz 183248 SHA256 442266c4bdb0f5c11e56f1e239b042faa4d501291158c7bc82de1d4632e7a20a SHA512 a0ffebd80ecb0ba2a4b49bebe68e71589069e48a1992b07b122dd52495847971d23aba4d7ee7a3ad88fd75f45a758f80ebeea9acbef45b0eeab2966ec952475b WHIRLPOOL 98395a7c81003b3598b6cf730d01b867b6378dcaff9ecf0fd55151189cb8fa03b2ac8cbc733800b2ef8b0810908f88387ac6b8d0a6c1b6576e068336ba5b05da
diff --git a/dev-ml/reason-parser/reason-parser-1.13.5.ebuild b/dev-ml/reason-parser/reason-parser-1.13.5.ebuild
new file mode 100644
index 000000000000..6313382e5d9d
--- /dev/null
+++ b/dev-ml/reason-parser/reason-parser-1.13.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib eutils
+
+DESCRIPTION="Meta Language Toolchain"
+HOMEPAGE="https://github.com/facebook/reason"
+SRC_URI="https://github.com/facebook/reason/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ >=dev-ml/menhir-20170418:=
+ dev-ml/merlin-extend:=
+ dev-ml/result:=
+ dev-ml/topkg:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_tools_versioned:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild
+ dev-ml/opam
+"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake compile_error
+ ocamlbuild -package topkg pkg/build.native || die
+ ./build.native build \
+ --native "$(usex ocamlopt true false)" \
+ --native-dynlink "$(usex ocamlopt true false)" \
+ || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}