summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-16 20:05:34 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-16 20:05:34 +0100
commit3e7e1c884b21f81461235974f76a004501b9db4b (patch)
treec982d69cf92a9c32a4178be1a32f83875f43a9d9 /dev-ml
parentdev-python/nuitka: add 0.6.19.3 (diff)
downloadgentoo-3e7e1c884b21f81461235974f76a004501b9db4b.tar.gz
gentoo-3e7e1c884b21f81461235974f76a004501b9db4b.tar.bz2
gentoo-3e7e1c884b21f81461235974f76a004501b9db4b.zip
dev-ml/opam-format: fix test DEPs
Closes: https://bugs.gentoo.org/794664 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-format/opam-format-2.0.10.ebuild9
-rw-r--r--dev-ml/opam-format/opam-format-2.0.8-r2.ebuild9
-rw-r--r--dev-ml/opam-format/opam-format-2.0.8-r3.ebuild9
-rw-r--r--dev-ml/opam-format/opam-format-2.0.9.ebuild7
-rw-r--r--dev-ml/opam-format/opam-format-2.1.0.ebuild15
-rw-r--r--dev-ml/opam-format/opam-format-2.1.1.ebuild15
6 files changed, 53 insertions, 11 deletions
diff --git a/dev-ml/opam-format/opam-format-2.0.10.ebuild b/dev-ml/opam-format/opam-format-2.0.10.ebuild
index ace83b9a6ae8..613461beb70d 100644
--- a/dev-ml/opam-format/opam-format-2.0.10.ebuild
+++ b/dev-ml/opam-format/opam-format-2.0.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,8 @@ OPAM_INSTALLER="${S}/opam-installer"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
RDEPEND="
~dev-ml/opam-core-${PV}:=
@@ -26,6 +27,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-ml/cppo"
+BDEPEND="test? (
+ sys-apps/bubblewrap
+ dev-ml/mccs
+)"
# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
diff --git a/dev-ml/opam-format/opam-format-2.0.8-r2.ebuild b/dev-ml/opam-format/opam-format-2.0.8-r2.ebuild
index eb552240221e..d873c3e60ab6 100644
--- a/dev-ml/opam-format/opam-format-2.0.8-r2.ebuild
+++ b/dev-ml/opam-format/opam-format-2.0.8-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,8 @@ OPAM_INSTALLER="${S}/opam-installer"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
RDEPEND="
<dev-lang/ocaml-4.12
@@ -27,6 +28,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-ml/cppo"
+BDEPEND="test? (
+ sys-apps/bubblewrap
+ dev-ml/mccs
+)"
src_prepare() {
default
diff --git a/dev-ml/opam-format/opam-format-2.0.8-r3.ebuild b/dev-ml/opam-format/opam-format-2.0.8-r3.ebuild
index 32abb96a8b97..6de06692f9c1 100644
--- a/dev-ml/opam-format/opam-format-2.0.8-r3.ebuild
+++ b/dev-ml/opam-format/opam-format-2.0.8-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,8 @@ OPAM_INSTALLER="${S}/opam-installer"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
RDEPEND="
~dev-ml/opam-core-${PV}:=
@@ -26,6 +27,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-ml/cppo"
+BDEPEND="test? (
+ sys-apps/bubblewrap
+ dev-ml/mccs
+)"
# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
diff --git a/dev-ml/opam-format/opam-format-2.0.9.ebuild b/dev-ml/opam-format/opam-format-2.0.9.ebuild
index 0f7882b1d5e3..db8f781018d3 100644
--- a/dev-ml/opam-format/opam-format-2.0.9.ebuild
+++ b/dev-ml/opam-format/opam-format-2.0.9.ebuild
@@ -16,7 +16,8 @@ OPAM_INSTALLER="${S}/opam-installer"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~x86"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
RDEPEND="
~dev-ml/opam-core-${PV}:=
@@ -26,6 +27,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-ml/cppo"
+BDEPEND="test? (
+ sys-apps/bubblewrap
+ dev-ml/mccs
+)"
# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
diff --git a/dev-ml/opam-format/opam-format-2.1.0.ebuild b/dev-ml/opam-format/opam-format-2.1.0.ebuild
index 027845d265fc..4c2a08d6886d 100644
--- a/dev-ml/opam-format/opam-format-2.1.0.ebuild
+++ b/dev-ml/opam-format/opam-format-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,8 @@ OPAM_INSTALLER="${S}/opam-installer"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
RDEPEND="
~dev-ml/opam-core-${PV}:=
@@ -27,6 +28,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-ml/cppo"
+BDEPEND="test? (
+ sys-apps/bubblewrap
+ dev-ml/mccs
+)"
PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
@@ -39,4 +44,10 @@ src_prepare() {
(release
(flags (:standard -warn-error -3-9-33))))
EOF
+ sed -i \
+ -e '/wrap-build-commands/d' \
+ -e '/wrap-install-commands/d' \
+ -e '/wrap-remove-commands/d' \
+ tests/reftests/opamroot-versions.test \
+ || die
}
diff --git a/dev-ml/opam-format/opam-format-2.1.1.ebuild b/dev-ml/opam-format/opam-format-2.1.1.ebuild
index 027845d265fc..4c2a08d6886d 100644
--- a/dev-ml/opam-format/opam-format-2.1.1.ebuild
+++ b/dev-ml/opam-format/opam-format-2.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,8 @@ OPAM_INSTALLER="${S}/opam-installer"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
RDEPEND="
~dev-ml/opam-core-${PV}:=
@@ -27,6 +28,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-ml/cppo"
+BDEPEND="test? (
+ sys-apps/bubblewrap
+ dev-ml/mccs
+)"
PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
@@ -39,4 +44,10 @@ src_prepare() {
(release
(flags (:standard -warn-error -3-9-33))))
EOF
+ sed -i \
+ -e '/wrap-build-commands/d' \
+ -e '/wrap-install-commands/d' \
+ -e '/wrap-remove-commands/d' \
+ tests/reftests/opamroot-versions.test \
+ || die
}