summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-05 17:42:46 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-06 00:09:11 +0200
commit00c7206cfb26e99903f26afe16850936ac95a1fe (patch)
tree5e2a5e00f70178f03ab64e7c1439d5864503476a /dev-ml
parentdev-ml/lablgtk: bump to 3.1.2 (diff)
downloadgentoo-00c7206cfb26e99903f26afe16850936ac95a1fe.tar.gz
gentoo-00c7206cfb26e99903f26afe16850936ac95a1fe.tar.bz2
gentoo-00c7206cfb26e99903f26afe16850936ac95a1fe.zip
dev-ml/lablgtk-sourceview: bump to 3.1.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgtk-sourceview/Manifest1
-rw-r--r--dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/lablgtk-sourceview/Manifest b/dev-ml/lablgtk-sourceview/Manifest
index f6a40d0e2049..f522691c1b6e 100644
--- a/dev-ml/lablgtk-sourceview/Manifest
+++ b/dev-ml/lablgtk-sourceview/Manifest
@@ -1 +1,2 @@
+DIST lablgtk-3.1.2.tar.gz 1042626 BLAKE2B 355ff285248129a063c041d3e64db33424ddbb71774128d7be980b8bd0b54cfa54b9d50b1c2f8527b8f6563836189ad72d30e4421b22d5938b888e61ada55056 SHA512 c63a492160f36685f65cb6bc0e72ff4939005acb2c65c56c0d9ba8f2112a618f24db84765e7b4416e49024048a36895028cfc5ef2c3e298dd4a309e902e34af5
DIST lablgtk3-3.1.1.tbz 854720 BLAKE2B e6a916151fe1ca0746c14c2a66cd178f3b0c051976815a1d13daf801002f16bc76d9f4cb15625353f0cfbdc16b0a218857d72c4e57125050bbcffe67f7096ad0 SHA512 193c340d9941680869eb90bc89f5b27cc5bdf294f4635081a9ba56a99fa2982266c4ee2eb5fd04d3a3f6150082800de5df786def8c72a276a779d843d914e9e3
diff --git a/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild b/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild
new file mode 100644
index 000000000000..fd85ad9de73a
--- /dev/null
+++ b/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=lablgtk3-sourceview3
+
+inherit dune
+
+DESCRIPTION="OCaml bindings to GTK-3"
+HOMEPAGE="https://github.com/garrigue/lablgtk"
+SRC_URI="https://github.com/garrigue/lablgtk/archive/${PV}.tar.gz
+ -> lablgtk-${PV}.tar.gz"
+S="${WORKDIR}"/lablgtk-${PV}
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="3/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/lablgtk-${PV}:3=
+ dev-ml/cairo2:=
+ x11-libs/gtksourceview:3.0=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ echo "(version ${PV})" >> "${S}"/dune-project || die
+}
+
+src_compile() {
+ dune build --profile release -p ${DUNE_PKG_NAME} || die
+}