summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-09 11:56:17 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-09 12:08:24 +0100
commit368bf1d4336df0a76cfbeed8323487405791a084 (patch)
tree72a600e1234a350f777aafeccf0dd9eb9ffcae8e /dev-ml/topkg
parentdev-ml/qcheck: bump to 0.5.1 (diff)
downloadgentoo-368bf1d4336df0a76cfbeed8323487405791a084.tar.gz
gentoo-368bf1d4336df0a76cfbeed8323487405791a084.tar.bz2
gentoo-368bf1d4336df0a76cfbeed8323487405791a084.zip
dev-ml/topkg: stop using opam-installer as it is an opam dep, bug #601906
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/topkg')
-rw-r--r--dev-ml/topkg/topkg-0.8.1.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-ml/topkg/topkg-0.8.1.ebuild b/dev-ml/topkg/topkg-0.8.1.ebuild
index 74067f192f14..806ffe6ad905 100644
--- a/dev-ml/topkg/topkg-0.8.1.ebuild
+++ b/dev-ml/topkg/topkg-0.8.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,18 +17,16 @@ IUSE=""
RDEPEND="dev-ml/result:=
dev-lang/ocaml:="
-DEPEND="${RDEPEND}
- dev-ml/opam"
+DEPEND="${RDEPEND}"
src_compile() {
ocaml pkg/pkg.ml build --pkg-name ${PN} || die
}
src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs="$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)"
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
dodoc CHANGES.md DEVEL.md README.md
}