summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 19:17:09 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit6f0dd3cbad0c811a461b87f32faff1f5dbdb2f6b (patch)
tree92545f341da3cec47bb45cd627a174dc14f657d0 /dev-ml/ppx_variants_conv
parentdev-ml/ppx_sexp_value: initial import; ebuild by me (diff)
downloadgentoo-6f0dd3cbad0c811a461b87f32faff1f5dbdb2f6b.tar.gz
gentoo-6f0dd3cbad0c811a461b87f32faff1f5dbdb2f6b.tar.bz2
gentoo-6f0dd3cbad0c811a461b87f32faff1f5dbdb2f6b.zip
dev-ml/ppx_variants_conv: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_variants_conv')
-rw-r--r--dev-ml/ppx_variants_conv/Manifest1
-rw-r--r--dev-ml/ppx_variants_conv/metadata.xml8
-rw-r--r--dev-ml/ppx_variants_conv/ppx_variants_conv-113.24.00.ebuild43
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/ppx_variants_conv/Manifest b/dev-ml/ppx_variants_conv/Manifest
new file mode 100644
index 000000000000..ee0051fe9084
--- /dev/null
+++ b/dev-ml/ppx_variants_conv/Manifest
@@ -0,0 +1 @@
+DIST ppx_variants_conv-113.24.00.tar.gz 55571 SHA256 753ee2c6c9115c4aed5069fd6792c3709bae1fa9f12356641aecd317be18ecd7 SHA512 3e4844defd3f29ee7a2435fefa3de1261e9b205700b3563f6b655d692cceaba17a3545785fd5b449d507312aa9e669b3943be3032151ea7b368f44adffaa64d5 WHIRLPOOL f11e264ddab17294eab0a779312aa0bcad8b0e06568d927fe97b2d5fd693ad56fcd5939147a162c01c00453b7d050e33a8396bcf97044ad88b1ef7c55c4578c5
diff --git a/dev-ml/ppx_variants_conv/metadata.xml b/dev-ml/ppx_variants_conv/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ppx_variants_conv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_variants_conv/ppx_variants_conv-113.24.00.ebuild b/dev-ml/ppx_variants_conv/ppx_variants_conv-113.24.00.ebuild
new file mode 100644
index 000000000000..54403e9cc86f
--- /dev/null
+++ b/dev-ml/ppx_variants_conv/ppx_variants_conv-113.24.00.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Generation of accessor and iteration functions for ocaml variant types"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/variantslib:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}