summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:49:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:59 +0200
commit6f0a36a698e75cba55ca15b22bf2368561f6590d (patch)
tree0e1c35e2872ffccf3b89384eb9fa394cb066c5cb /dev-ml/ppx_pipebang
parentdev-ml/typerep_extended: bump to 0.9.0 (diff)
downloadgentoo-6f0a36a698e75cba55ca15b22bf2368561f6590d.tar.gz
gentoo-6f0a36a698e75cba55ca15b22bf2368561f6590d.tar.bz2
gentoo-6f0a36a698e75cba55ca15b22bf2368561f6590d.zip
dev-ml/ppx_pipebang: bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_pipebang')
-rw-r--r--dev-ml/ppx_pipebang/Manifest2
-rw-r--r--dev-ml/ppx_pipebang/files/oc43.patch46
-rw-r--r--dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild31
-rw-r--r--dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild44
4 files changed, 32 insertions, 91 deletions
diff --git a/dev-ml/ppx_pipebang/Manifest b/dev-ml/ppx_pipebang/Manifest
index e68031d7ff81..e2a633025da2 100644
--- a/dev-ml/ppx_pipebang/Manifest
+++ b/dev-ml/ppx_pipebang/Manifest
@@ -1 +1 @@
-DIST ppx_pipebang-113.33.00.tar.gz 51353 SHA256 6e43998c5161b87f71a38d197f9d5898ab8ac0e8f7612db64b5c848ee6709204 SHA512 9c057c756b3dbf0ad2306cfc61e9874cb11e050ade05ab2686cfd043fec5e52c17c197aaf6f3ba65c032aa66e810964c4c03b72af64f98e47bf8d532806f62e8 WHIRLPOOL 7a61889c3857591b7f596874d6665f55065d826ed1c6bf645c541816aeafbefec528826dfb48914d875ee9c6ce30f2709d9798aed4d46487827baa2a43eef920
+DIST ppx_pipebang-0.9.0.tar.gz 5964 SHA256 5e1021290a2c0514227cef2b34d3d78a199c51233225c8f04146914a10c7ef40 SHA512 d0e82152d257f7214e577e37046877a9c4129c6a9fd79f83912c6335455add4302d927e70117a1e9386c448686d271a7596b3fd2ef0b5f2bda8010cbb9157751 WHIRLPOOL 50d7d91e9be78efb0001d676698605768ec0001a1968d1bc247761d828e42957c8c2d0042c3832a4880f162d55076a354c7ef7e525c3acb31608f41ca921802c
diff --git a/dev-ml/ppx_pipebang/files/oc43.patch b/dev-ml/ppx_pipebang/files/oc43.patch
deleted file mode 100644
index 5f10fc02053f..000000000000
--- a/dev-ml/ppx_pipebang/files/oc43.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -uNr ppx_pipebang-113.33.00/_oasis ppx_pipebang-113.33.00+4.03/_oasis
---- ppx_pipebang-113.33.00/_oasis 2016-03-09 16:44:54.000000000 +0100
-+++ ppx_pipebang-113.33.00+4.03/_oasis 2016-03-22 15:13:51.000000000 +0100
-@@ -1,8 +1,8 @@
- OASISFormat: 0.4
--OCamlVersion: >= 4.02.3
-+OCamlVersion: >= 4.03.0
- FindlibVersion: >= 1.3.2
- Name: ppx_pipebang
--Version: 113.33.00
-+Version: 113.33.00+4.03
- Synopsis: A ppx rewriter that inlines reverse application operators `|>` and `|!`
- Authors: Jane Street Group, LLC <opensource@janestreet.com>
- Copyrights: (C) 2015-2016 Jane Street Group LLC <opensource@janestreet.com>
-diff -uNr ppx_pipebang-113.33.00/opam ppx_pipebang-113.33.00+4.03/opam
---- ppx_pipebang-113.33.00/opam 2016-03-18 12:08:01.000000000 +0100
-+++ ppx_pipebang-113.33.00+4.03/opam 2016-03-22 17:51:37.000000000 +0100
-@@ -16,4 +16,4 @@
- "ppx_driver"
- "ppx_tools" {>= "0.99.3"}
- ]
--available: [ ocaml-version >= "4.02.3" ]
-+available: [ ocaml-version >= "4.03.0" ]
-diff -uNr ppx_pipebang-113.33.00/src/ppx_pipebang.ml ppx_pipebang-113.33.00+4.03/src/ppx_pipebang.ml
---- ppx_pipebang-113.33.00/src/ppx_pipebang.ml 2016-03-09 16:44:54.000000000 +0100
-+++ ppx_pipebang-113.33.00+4.03/src/ppx_pipebang.ml 2016-03-22 15:13:51.000000000 +0100
-@@ -11,16 +11,16 @@
- let loc = e.pexp_loc in
- match e.pexp_desc with
- | Pexp_apply ({ pexp_desc = Pexp_ident { txt = Lident ("|!" | "|>"); _ }; _ },
-- [("", x); ("", y)]) -> begin
-+ [(Nolabel, x); (Nolabel, y)]) -> begin
- let x = self#expression x in
- let y = self#expression y in
- match y with
- | { pexp_desc = Pexp_construct (id, None); _ } ->
- { y with pexp_desc = Pexp_construct (id, Some x) }
- | { pexp_desc = Pexp_apply (f, args); pexp_attributes = []; _ } ->
-- { e with pexp_desc = Pexp_apply (f, args @ [("", x)]) }
-+ { e with pexp_desc = Pexp_apply (f, args @ [(Nolabel, x)]) }
- | _ ->
-- { e with pexp_desc = Pexp_apply (y, [("", x)]) }
-+ { e with pexp_desc = Pexp_apply (y, [(Nolabel, x)]) }
- end
- | Pexp_ident { txt = Lident ("|!" | "|>" as s); _ } ->
- Location.raise_errorf ~loc "%s must be applied to two arguments" s
diff --git a/dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild b/dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild
new file mode 100644
index 000000000000..8d864327b5a2
--- /dev/null
+++ b/dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A ppx rewriter that inlines reverse application operators |> and |!"
+HOMEPAGE="https://github.com/janestreet/ppx_pipebang"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild b/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild
deleted file mode 100644
index 5c92a8175ac9..000000000000
--- a/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit oasis
-
-DESCRIPTION="A ppx rewriter that inlines reverse application operators |> and |!"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-ml/ppx_tools:=
- dev-ml/ppx_core:=
- dev-ml/ppx_driver:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam"
-
-src_prepare() {
- has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
-}
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc README.md
-}