summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-24 10:30:34 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-24 10:30:34 +0200
commitbac60b0e784db4d01077322e213656c6197acc08 (patch)
tree3f90a310683bb6ded373acf67461bc9a53fdc046 /dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild
parentpackage.mask: add ppx_hash to janestreet mask (diff)
downloadgentoo-bac60b0e784db4d01077322e213656c6197acc08.tar.gz
gentoo-bac60b0e784db4d01077322e213656c6197acc08.tar.bz2
gentoo-bac60b0e784db4d01077322e213656c6197acc08.zip
dev-ml/ppx_hash: 0.15.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild')
-rw-r--r--dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild b/dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild
new file mode 100644
index 000000000000..287a652b531d
--- /dev/null
+++ b/dev-ml/ppx_hash/ppx_hash-0.15.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="PPX rewriter that generates hash functions from type expressions and definitions"
+HOMEPAGE="https://github.com/janestreet/ppx_hash"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:${SLOT}
+ dev-ml/ppx_compare:${SLOT}
+ dev-ml/ppx_sexp_conv:${SLOT}
+ >=dev-ml/ppxlib-0.23.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"