summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 16:02:10 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commitcea1f17e2227b282c329afe0ff07083f7aa9ebd8 (patch)
tree7a17d0f9eecf98975eae9b41d20984319c29c1eb /dev-ml/ppx_deriving
parentdev-ml/ppx_core: initial import; ebuild by me (diff)
downloadgentoo-cea1f17e2227b282c329afe0ff07083f7aa9ebd8.tar.gz
gentoo-cea1f17e2227b282c329afe0ff07083f7aa9ebd8.tar.bz2
gentoo-cea1f17e2227b282c329afe0ff07083f7aa9ebd8.zip
dev-ml/ppx_deriving: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_deriving')
-rw-r--r--dev-ml/ppx_deriving/Manifest1
-rw-r--r--dev-ml/ppx_deriving/metadata.xml8
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-3.0.ebuild53
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving/Manifest b/dev-ml/ppx_deriving/Manifest
new file mode 100644
index 000000000000..58d9aa2ca430
--- /dev/null
+++ b/dev-ml/ppx_deriving/Manifest
@@ -0,0 +1 @@
+DIST ppx_deriving-3.0.tar.gz 38560 SHA256 1998607e68b35b6c61e1fb33c03b523f3bf88f802df6d5bf180dc6932317179b SHA512 1b8ef40fd1b85df0d5307edcc46c16ae1834aadb1419d92dced4b2b542f51bb24999abcdf725647f1f7033ca2df4dc88ab156002b1e6a7a6a83a5e0e4854d833 WHIRLPOOL cda0c6afc31c6d39dd4974c2ce63d28ddea2019bb8bc1c50338c1005880a0a0ef66c2ceb00e86a6a7040c042778f1216321cda3d1dcfc2327c6e084f0ab45b53
diff --git a/dev-ml/ppx_deriving/metadata.xml b/dev-ml/ppx_deriving/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ppx_deriving/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_deriving/ppx_deriving-3.0.ebuild b/dev-ml/ppx_deriving/ppx_deriving-3.0.ebuild
new file mode 100644
index 000000000000..933139f96558
--- /dev/null
+++ b/dev-ml/ppx_deriving/ppx_deriving-3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Type-driven code generation for OCaml"
+HOMEPAGE="https://github.com/whitequark/ppx_deriving"
+SRC_URI="https://github.com/whitequark/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt test"
+
+DEPEND="dev-ml/ppx_tools:=
+ >=dev-lang/ocaml-4.02.3:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ cp pkg/META.in pkg/META || die
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+ use doc && emake doc
+}
+
+src_test() {
+ ocamlbuild -j 0 -use-ocamlfind -classic-display \
+ src_test/test_ppx_deriving.byte -- || die
+ if use ocamlopt; then
+ ocamlbuild -j 0 -use-ocamlfind -classic-display \
+ src_test/test_ppx_deriving.native -- || die
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ # Copied from upstream makefile
+ grep -E '^[[:space:]]+' ppx_deriving.install | \
+ awk '{ print $1 }' | \
+ sed -e 's:"?*::g' | \
+ xargs ocamlfind install ppx_deriving || die
+
+ use doc && dohtml api.docdir/*
+
+ dodoc CHANGELOG.md README.md
+}