summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-22 10:16:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-22 10:31:39 +0200
commit6b667b2703b5fdca32a26bfab2cb6374760efee1 (patch)
tree3f5f608386382962396bba5caf8d9141de61ad34 /dev-ml/ppx_compare/ppx_compare-0.9.0-r1.ebuild
parentdev-ml/ppx_custom_printf: update to opam.eclass (diff)
downloadgentoo-6b667b2703b5fdca32a26bfab2cb6374760efee1.tar.gz
gentoo-6b667b2703b5fdca32a26bfab2cb6374760efee1.tar.bz2
gentoo-6b667b2703b5fdca32a26bfab2cb6374760efee1.zip
dev-ml/ppx_compare: update to opam.eclass
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ppx_compare/ppx_compare-0.9.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_compare/ppx_compare-0.9.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_compare/ppx_compare-0.9.0-r1.ebuild b/dev-ml/ppx_compare/ppx_compare-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..b1de7abe2612
--- /dev/null
+++ b/dev-ml/ppx_compare/ppx_compare-0.9.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Generation of comparison functions from types"
+HOMEPAGE="https://github.com/janestreet/ppx_compare"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/ppx_core:=
+ dev-ml/base:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_metaquot:=
+"
+
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"